Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So here's my problem: When I run wubi, it asks for admin rights so I hit "Yes." Then, the mouse has the loading sign next to it and disappears, nothing happens. So here's the log:

04-13 17:14 INFO   root: === wubi 12.10 rev273 ===
04-13 17:14 DEBUG  root: Logfile is c:\users\roperson\appdata\local\temp\wubi-12.10-rev273.log
04-13 17:14 DEBUG  root: sys.argv = ['main.pyo', '--exefile="C:\\Users\\roperson\\Desktop\\wubi.exe"']
04-13 17:14 DEBUG  CommonBackend: data_dir=C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\data
04-13 17:14 DEBUG  WindowsBackend: 7z=C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\bin\7z.exe
04-13 17:14 DEBUG  WindowsBackend: startup_folder=C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup
04-13 17:14 DEBUG  CommonBackend: Fetching basic info...
04-13 17:14 DEBUG  CommonBackend: original_exe=C:\Users\roperson\Desktop\wubi.exe
04-13 17:14 DEBUG  CommonBackend: platform=win32
04-13 17:14 DEBUG  CommonBackend: osname=nt
04-13 17:14 DEBUG  CommonBackend: language=en_US
04-13 17:14 DEBUG  CommonBackend: encoding=cp1252
04-13 17:14 DEBUG  WindowsBackend: arch=amd64
04-13 17:14 DEBUG  CommonBackend: Parsing isolist=C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\data\isolist.ini
04-13 17:14 DEBUG  CommonBackend:   Adding distro Edubuntu-i386
04-13 17:14 DEBUG  CommonBackend:   Adding distro Kubuntu-amd64
04-13 17:14 DEBUG  CommonBackend:   Adding distro Mythbuntu-i386
04-13 17:14 DEBUG  CommonBackend:   Adding distro Edubuntu-amd64
04-13 17:14 DEBUG  CommonBackend:   Adding distro Ubuntu-amd64
04-13 17:14 DEBUG  CommonBackend:   Adding distro Lubuntu-i386
04-13 17:14 DEBUG  CommonBackend:   Adding distro Ubuntu-i386
04-13 17:14 DEBUG  CommonBackend:   Adding distro Mythbuntu-amd64
04-13 17:14 DEBUG  CommonBackend:   Adding distro Kubuntu-i386
04-13 17:14 DEBUG  CommonBackend:   Adding distro Lubuntu-amd64
04-13 17:14 DEBUG  WindowsBackend: Fetching host info...
04-13 17:14 DEBUG  WindowsBackend: registry_key=Software\Microsoft\Windows\CurrentVersion\Uninstall\Wubi
04-13 17:14 DEBUG  WindowsBackend: windows version=vista
04-13 17:14 DEBUG  WindowsBackend: windows_version2=Windows 7 Enterprise
04-13 17:14 DEBUG  WindowsBackend: windows_sp=None
04-13 17:14 DEBUG  WindowsBackend: windows_build=7601
04-13 17:14 DEBUG  WindowsBackend: gmt=-5
04-13 17:14 DEBUG  WindowsBackend: country=US
04-13 17:14 DEBUG  WindowsBackend: timezone=America/New_York
04-13 17:14 DEBUG  WindowsBackend: windows_username=roperson
04-13 17:14 DEBUG  WindowsBackend: user_full_name=roperson
04-13 17:14 DEBUG  WindowsBackend: user_directory=C:\Users\roperson
04-13 17:14 DEBUG  WindowsBackend: windows_language_code=1033
04-13 17:14 DEBUG  WindowsBackend: windows_language=English
04-13 17:14 DEBUG  WindowsBackend: processor_name=AMD Phenom(tm) II X2 560 Processor
04-13 17:14 DEBUG  WindowsBackend: bootloader=vista
04-13 17:14 DEBUG  WindowsBackend: system_drive=Drive(C: hd 205574.089844 mb free ntfs)
04-13 17:14 DEBUG  WindowsBackend: drive=Drive(C: hd 205574.089844 mb free ntfs)
04-13 17:14 DEBUG  WindowsBackend: drive=Drive(D: cd 4338.66601563 mb free udf)
04-13 17:14 DEBUG  WindowsBackend: uninstaller_path=C:\ubuntu\uninstall-wubi.exe
04-13 17:14 DEBUG  WindowsBackend: previous_target_dir=C:\ubuntu
04-13 17:14 DEBUG  WindowsBackend: previous_distro_name=Ubuntu
04-13 17:14 DEBUG  WindowsBackend: keyboard_id=67699721
04-13 17:14 DEBUG  WindowsBackend: keyboard_layout=us
04-13 17:14 DEBUG  WindowsBackend: keyboard_variant=
04-13 17:14 DEBUG  CommonBackend: python locale=('en_US', 'cp1252')
04-13 17:14 DEBUG  CommonBackend: locale=en_US.UTF-8
04-13 17:14 DEBUG  WindowsBackend: total_memory_mb=3580.53515625
04-13 17:14 DEBUG  CommonBackend: Searching ISOs on USB devices
04-13 17:14 DEBUG  CommonBackend: Searching for local CDs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Ubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Ubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Kubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Kubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Mythbuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Mythbuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Edubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Edubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Lubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp is a valid Lubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain C:\Users\roperson\AppData\Local\Temp\pyl6EAA.tmp\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Ubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Ubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Kubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Kubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Mythbuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Mythbuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Edubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Edubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Lubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 DEBUG  Distro:   checking whether D:\ is a valid Lubuntu CD
04-13 17:14 DEBUG  Distro:     does not contain D:\casper\filesystem.squashfs
04-13 17:14 INFO   root: Already installed, running the uninstaller...
04-13 17:14 INFO   root: Running the uninstaller...
04-13 17:14 INFO   CommonBackend: Launching previous uninestaller C:\ubuntu\uninstall-wubi.exe
04-13 17:14 ERROR  root: [Errno 193] %1 is not a valid Win32 application
Traceback (most recent call last):
  File "\lib\wubi\application.py", line 58, in run
  File "\lib\wubi\application.py", line 132, in select_task
  File "\lib\wubi\application.py", line 145, in run_installer
  File "\lib\wubi\application.py", line 175, in run_uninstaller
  File "\lib\wubi\backends\common\backend.py", line 874, in run_previous_uninstaller
  File "\lib\subprocess.py", line 425, in call
  File "\lib\subprocess.py", line 547, in __init__
  File "\lib\subprocess.py", line 701, in _execute_child
WindowsError: [Errno 193] %1 is not a valid Win32 application

Can anyone help me understand what's going on?

share|improve this question

2 Answers 2

maybe you should try the more stable wubi 12.04.2 LTS

Also you might want to delete the Ubuntu folder that the previous install created, that might fix it

share|improve this answer

It seems like it's trying to uninstall a previously installed version (this can happen even if the previous install failed). It's trying to run C:\ubuntu\uninstall-wubi.exe and this is what appears to be failing. Hard to tell exactly, but you can follow the manual uninstallation instructions to clean up the remnants of the old installation before trying to install again. That should get it working.

Refer to instructions here: How do I manually uninstall Wubi

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.