Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here's the situation:

I start my main computer from another pc via wake on lan "wakeonlan ". All works fine. When I'm done doing what I did, I run "sudo shutdown -h now" (in the ssh terminal in which I was working) to shutdown the computer. But instead of shutting down, it reboots. I then have to reconnect to it via ssh and run the shutdown command again, and then it shuts down and stays off. I can then start it again via wake on lan...

does anyone know, why my computer actually reboots when I type "sudo shutdown -h now" when started via wake on lan?

Some information about the computer:

Ubuntu 13.04
Moterboard: Gigabyte GA-Z77X-UD3H
Ethernet Controller (as reported by "lspci"): Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet (rev c0)

share|improve this question
    
patsee, I'm facing the same issue. Any solutions? –  FireAndIce May 24 '13 at 8:28
1  
What (EFI?) BIOS version do you have? Others (including me) have reported the same issue with an Asus and GA-Z68X-UD3H-B3 board containing a Realtek card lists.debian.org/debian-user/2013/06/msg01280.html –  Lekensteyn Jun 27 '13 at 12:27
    
I'm having the same problem with the Asus P8H61-M LE/CSM with a Realtek Ethernet card. Has anybody come up with some workaround for this? I read the debian email, but I also don't have Windows installed to test this behaviour. –  Felipe Sep 24 '13 at 16:23
add comment

2 Answers

I had this issue too, using the Intel DQ77MK motherboard, which has 2 onboard Intel GB ethers. I fixed it by enabling the power bios entry "Native ACPI OS PCIe Support", which I guess allowed Ubuntu to reset the flag saying WOL has been triggered, probably with it disabled Ubuntu was not allowed by the BIOS to reset the flag.

share|improve this answer
    
Thanks for your answer, but unfortunately my bios does not have this option nor was I able to find a similar one. The problem still persists. –  patsee Aug 10 '13 at 20:33
add comment

Try sudo poweroff.

It works better with WOL for me.

share|improve this answer
    
thanks for your suggestion. I just tried to shutdown via "sudo poweroff" but unfortunately it is the same behavior as written in my op. –  patsee May 4 '13 at 7:31
1  
This is the same as shutdown -h, seriously. –  gertvdijk Jul 14 '13 at 13:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.