Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After several tries I managed to install Ubuntu 12.04 in EFI mode (GPT partition table) on my DELL Inspiron 15z. What worked for me is what is in this post http://askubuntu.com/a/224332/149034, i.e. I set the BIOS in legacy mode and then choose to boot (F12 at stuart-up) the 12.04 Live CD in EFI mode. In this way I get Ubuntu installed in a GPT partition table , with EFI boot loader.

The problem is that now, to start Ubuntu, I have to repeat these steps everytime:

  • The boot is set in legacy mode from BIOS.

  • I press F12 at start-up to choose to boot Ubuntu in UEFI mode.

If I set UEFI mode directly in BIOS, after grub, I get a blank (purple) screen, and Ubuntu does not start.

Secure boot is disabled, and I tried fixing it with boot-repair but did not succeed.

Does anyone have a clue of what is the problem?

I discovered this is related to a bug

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1093472 https://answers.launchpad.net/ubuntu-certification/+question/217551 Ubuntu 12.10 boot hangs at purple screen when integrated NIC (ethernet card) is enabled in BIOS

it turns out that deactivating integrated NIT in BIOS the UEFI boots starts directly. But wirh no ethernet....

share|improve this question
    
Some systems initialize their hardware differently if BIOS/CSM/legacy mode is enabled than if it isn't, and this can affect subsequent boot steps. It's possible that this is what you're seeing, and if so, the solution is just to leave BIOS/CSM/legacy mode enabled in the firmware, even though you're booting in EFI mode. There's no real problem with this, although it may add a few seconds to the boot time. If you're running into an actual problem with this, please elaborate. –  Rod Smith Apr 13 '13 at 17:47
    
Thanks for the answer. I added some lines to the post, and it seems to be an issue related with atheos card. Anyway the problem is that I have to press F12 every time I switch on my laptop, to –  jack Apr 13 '13 at 19:14
    
boot Ubuntu in EFI. If I don't do that it simply does not boot, 'cause ubuntu is installed with EFI bootloader, not legacy. –  jack Apr 13 '13 at 19:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.