Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some trouble getting the Nvidia drivers to work properly on Ubuntu 12.10. My pc is a sony svs13 that comes with an integrated intel HD graphics and a dedicated Nvidia GT 430M LE. I have searched the forums and the web for various solutions but none have worked so far. The new jockey interface (software sourcers->proprietary drivers) shows an empty list and that no thrid party drivers are in use. I have tried both the apt-get nvidia drivers (current & current-updates) and the Nvidia's drivers. I have downloaded the drivers according to the video board model on Nvidia's website but on installation it tells me that there is no graphics card compatible. The dedicated graphics is enabled on bios and as far as I can tell they seem to be working (it came with win8 pre-installed where it worked).

Here are some outputs asked for on similar threads:

lspci
00:02.0 VGA compatible controller: Intel Corp 3rd Gen Core processor .... (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd3 (dev a1)


lshw -c video
*-display UNCLAIMED
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.1
version: a1
width: 64 bits
clock: 33Mhz
capabilities: pm msi pciexpress vga_controller bus_master cap_list
configuration: latency=0
resources: memory:[hexcode] memory:... ... ioport:6000(size=128)

*-display
description: VGA Compatible controller
product: 3rd Gen Core processor graphics controller
....
<rest of intel's info>

sorry for any typos & abreviations, im posting from a different computer.

What I have tried so far:

  • blacklist other devices on the /etc/modprobe.d/blacklsit i.e vga16fb nouveau rivafb nvidiafb and rivatv

  • install linux-generic & linux-headers-generic from apt-get

  • install bumblebee from apt-get (adding the proper repository)

  • install both nvidia-current & nvidia's website drivers

What happens: If i run nvidia-settings it tells me nvidia drivers are not beeing used. Even after driver is installed nothing shows on the software repository tab. If i run nvidia-xconfig it creates a xorg.conf file that totally breaks my screens resolution to 640x400 & gives my a popup error on login about CRC modes not supported. External displays (HDMI port) seem to work normally. If i delete xorg.conf file no other file is created and resolution works fine (I'm able to change to any resolution). Even with the xorg.conf file deleted compiz/unity are unable to start. They give a opengl plugin error:

compiz (opengl) - Fatal: glxQueryExtensionsString is NULL for screen 0

in order to fix compiz/unity I have tried the following:

  • reinstall both + ubuntu-desktop from apt-get
  • install & run unity-reset
  • disableling VGA options on xdiagone
  • disableling the opengl pluing on ccsm

Everything I have tried so far was based on suggestions from other threads and have gotten no avail so far. I have checked for compatibility issues but have not found anything suggesting my card is not compatible (it even lists on NVIDA's website for this driver).

What is enabled/used atm: * drivers listed on blacklist.conf * no xorg.conf file * Nvidia's website latest driver is installed - 64bits 310.44 * bumblebee is installed

The following messages come up during nvidia-current installation from apt-get:

trying to match Sony Corporation to Lenovo .. failed
trying to match Sony Corporation to Dell .. failed
trying to match Sony Corporation to <name> .. failed

after many such attempts it tells me it is building to generic and completes sucessfully the installation. The nvidia-detect command also wields

none

please help, any insights beyond use intels card would be appreciated. I sometimes require to do CUDA programming/test for computer vision algorithms benchmarking and need the dedicated graphics. Thank you in advance. ...sorry for the long text, trying to be helpful.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.