Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install FGLRX drivers on Ubuntu 13.04, but that didn't work out.

I then went back to the open source drivers (via update-manager) but I couldn't boot into a graphical OS.

I got a black screen with a prompt to log in.

I got in, launched lightdm manually, and reinstalled the OSS drivers... and now I have them installed, and I even seem to be using them (chrome://gpu reports that I am, and I can move things around the screen).

But everything is screwed up - I can't get Unity to launch, I'm still booting into the black screen, and I can't seem to fix this.

Help?

edit: I removed fglrx completely, and I now boot into a UI, but it's just a desktop background. No Unity.

edit2: I can now launch Unity manually... but it doesn't have any of my old settings, and doesn't have any plugins etc. So that's still not working great.

edit3: I went into CCSM and reenabled all of the plugins like Unity and gave default settings. IDK what else but something broke Unity, I can no longer launch it.

share|improve this question
    
try making a new user profile and, check Unity works in it –  Naveen Apr 13 '13 at 8:49
    
@Naveen: I tried to reproduce the problem that the OP was asking about. Everything that the OP described happened in my case. Making new user gives unity back, but it is unbelievably slow. I suppose somewhere in the XOrg system, drivers/settings got messed up. Generating a new xorg.conf didn't help. –  William Apr 25 '13 at 0:36
    
Have you tried this with KDE? I wonder if this is a Unity thing only. –  William Apr 25 '13 at 6:38
add comment

1 Answer

I managed to fix my Unity by switching back to the Xorg driver and renaming the ~/.config folder. I'm not sure exactly which configs got messed up, but starting fresh without config files worked for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.