Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I love OpenDNS and I love Google and I love Firefox but they do not play nicely together.

OpenDNS gives me awesome functionality beyond any other DNS server right now so that I can LOCK my internet to my desired settings. GoogleDNS is coming along but NOWHERE NEAR the functionality.

One little problem. The following standard tweak to set the Firefox URL bar to do Google searches, DOES NOT WORK

1) type about:config in url bar  
2) for keyword.URL type https://www.google.com/search?btnG=Google+Search&q=  
3) set keyword.enabled to true  

Doing this tweak does nothing (in Ubuntu 12.04 Firefox version 20 (ubuntu for powerpc))

How can I get my Google seach back whilst keeping my beloved OpenDNS?
Firefox is the only browser that has this problem.

share|improve this question
1  
I don't think this is a duplicate question because the other questions don't seem to care about KEEPING openDNS. My question is how to use BOTH services while the other questions seem to throw away opendns –  Joshua Robison Apr 13 '13 at 1:29
    
Here is a tweak kind of workaround but still not the complete perfect answer askubuntu.com/a/165986/13177 –  Joshua Robison Apr 13 '13 at 1:35

2 Answers 2

up vote 1 down vote accepted

There is no way to do this but you can somewhat get around it by

go to www.google.com

Then right click in the search bar and select make a keyword for this searchbar

set the keyword to something like gg

Now you can start your searches with gg and search. .

I hate that there is no way to fix firefox to work WITH opendns because I love firefox and I love opendns. Why does Google Chrome work and firefox doesn't - ridiculous.

share|improve this answer

You probably have openDNS set up on your router....

You can change this on your computer by:

  1. Searching network connections.

  2. Then edit the connection that you are using.

  3. Click the IPv4 Settings tab.

  4. In the DNS servers type: 8.8.8.8,8.8.4.4

  5. Save, then disconnect and reconnect.

Hope this helps.

share|improve this answer
    
you didn't read the question did you –  Joshua Robison Apr 13 '13 at 1:52
    
yes I did... I just now noticed that he wanted to keep his openDNS... my bad! :) –  Leinardo Smith Apr 13 '13 at 3:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.