Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 13.04 today with gnome(First Ubuntu 13.04, then apt-get install gnome-shell). After this my boot screen is broken, you can see this here:

broken screen

This happened at Ubuntu 12.04 and Ubuntu 12.10 after installing gnome-shell(For gnome 3 desktop environment), too, at shutdown and start. How can I fix this?

Additional information about graphic card and driver:

Name: GeForce GTX 560 Ti

Driver: 310.44

share|improve this question
    
Use a live cd and check the results of ls -l /var (or put them in the question). Check for symbolic links from /run to /var/run and /run/lock to /var/run/lock. By the way: 13.04 is beta software and installing gnome-shell might be bugged. If so we can not help you. If this also happend on 12.10 I would advice tagging it 12.10 and not 13.04. –  Rinzwind Apr 12 '13 at 19:33

3 Answers 3

I had the exact same problem and found a working solution (for me). Original information from this blog: http://jechem.blogspot.be/2011/04/fix-plymouth-splash-screen-in-ubuntu-on.html

First install hwinfo by running the following command:

sudo apt-get install v86d hwinfo

After the installation run the following command and note down the highest resolution:

sudo hwinfo --framebuffer

For me this was Mode 0x0361: 1280x800 (+5120), 24 bits, next edit the following file:

gksu gedit /etc/default/grub

This will open the GRUB config file, we now look for GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and change it with the following, change your resolution with mine and also add the color depth (for me 24 could be 16 or 32).

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1280x800-24,mtrr=3,scroll=ywrap"

Then find the following line (uncomment if needed) and change your resolution again, note that you don't include the color depth:

GRUB_GFXMODE=1280x800

Save and exit, next edit the following file:

gksu gedit /etc/initramfs-tools/modules

Scroll to the end of the file and add the following line, again add your resolution and the colordepth like you did before:

uvesafb mode_option=1280x800-24 mtrr=3 scroll=ywrap

Then in the terminal type the following commands and then reboot:

echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
sudo update-grub
sudo update-initramfs -u

For me this fixed the problem, I tried all the other suggestions and scripts, none of them worked but this does, good luck!

share|improve this answer

@JackLock, most probably your problem is unrelated to gnome-shell. It's caused by installing NVIDIA proprietary drivers. Look up this thread, for instance; there are plenty similar discussions on Ubuntu forums. There are all sorts of workarounds, but AFAIK the problem does not have a fix or solution.

share|improve this answer

See: http://www.webupd8.org/2010/10/script-to-fix-ubuntu-plymouth-for.html

It's an old fix, but still relevant. Same problem in Mint 14

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom May 20 '13 at 10:36
    
This fix is an extremely bad idea. Even though it might work, for many it doesn't. It changes stuff in a bad way and is not easily reversible. Don't use! –  mniess Jun 30 '13 at 14:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.