Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've bought a split ergonomic keyboard, and wish to bind the left spacebar to space. I'm attempting to use xmodmap, which binds it fine when pressed alone, except it does not correctly recognise ctrl+space.

Here is what I've tried. To determine the correct bindings I should use, I did

$ xmodmap -pke | grep space
keycode  65 = space NoSymbol space

From xev, the right space is indeed 65, and the left is 103. Hence, I ran

$ xmodmap -e 'keycode 103 = space NoSymbol space
$ xmodmap -pke | grep space
keycode  65 = space NoSymbol space
keycode 103 = space NoSymbol space

Now, the left spacebar sends space, but ctrl+space doesn't work (I use this to trigger guake). Oddly enough, if I bind space NoSymbol space to keycode 10 (the 1 key), then ctrl+space works for 1, but not for the right spacebar now! Perhaps the lowest number is the only one that's working?

FWIW, I've also tried adding another / bound to an additional key, and ctrl+/ seems to work fine for both (at least in RubyMine).

An addendum: if I check the space keystroke (without modifier) with xev, I get slightly different results for the working space as opposed to the partially-working space(s). If the working space is keycode foo, then I get an additional line for the partially-working spaces.

XKeysymToKeycode returns keycode: foo
share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.