Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using an old X60 that I bought from Japan. Naturally, it has a Japanese keyboard.

When installing 12.10, I chose the closest keyboard layout I could find: Japanese(OADG 109A). But somehow my keyboard doesn't respond to the Japanese switch key so I'm stuck with typing in English only.

I have installed the Japanese language and Japanese Anthy(ibus). Those work fine.

What I really want is to type in Japanese via the Hiragana printed characters on the keyboard.

This is the first time I am using a Japanese keyboard, so any help would be appreciated.

share|improve this question
add comment

3 Answers 3

I would try and reinstall Ubuntu but when you select your keyboard, try 'detect keyboard layout'.

share|improve this answer
add comment

Go to System Settings -> Keyboard -> Keyboard Layout and try adding and trying other layouts, see if any of them work.

Here, I just tried with one named Kana, and it types directly in Japanese.

share|improve this answer
add comment

Did you mean Kana input?

ibus-anthy has multiple ways of entering the kana. Default mode is via phonetic romaji (roman alphabets). You can change the input mode to Kana input, which uses the hiragana on the keyboard as you asked.

Since you got ibus-anthy set up, I assume have a toolbar like this floating on your desktop or glued to your panel (source: Ubuntulinux.jp Wiki article on IbusAnthy):

Toolbar of ibus-anthy

See the third button from the left, with the symbol R. That is the button for selecting input type. R denotes romaji input type. Kana input should be selectable by clicking on that button.


There are a couple of things I need to confirm though:

  1. You said you chose OADG 109A but the Japanese switch key didn't respond. Does other buttons, say, like the @ key map correctly?
  2. I assume by Japanese switch key you mean the one to the left of 1 key, i.e. the Zenkaku_Hankaku key. Di you mean that pressing that key didn't enable Japanese (romaji) input mode? It's possible that your ibus-anthy didn't have Zenkaku_Hankaku as the shortcut to toggle Japanese input. It's configurable via Anthy preferences.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.