Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whenever I plug any type of headphones into one of the audio out connectors on my hp dv6, alsa mutes them, muting the "speaker" setting(see attached image). This also happened in Fedora, so it's a problem with Alsa and my computer. Does anyone know anything that would help?

Note, I don't have enough reputation for images. Here's a link: Image

Thank you so much if you can help!

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I found a solution that works here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/921397/comments/9

You can also see the whole discussion regarding this bug here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/921397

To summarize:

Edit sudo gedit /usr/share/pulseaudio/alsa-mixer/paths/analog-output-headphones.conf

and modify the [Element Speaker] section as follows:

[Element Speaker]
; link to muting
switch = mute
; set volume to zero, so only the master slider controls playback volume. This gives better linearity.
volume = zero

After this, I had to restart the system: you might try to restart only pulse audio with pulseaudio -k.

I also had an additional problem, that I fixed before solving the above. Namely, my headphones didn't work at all. I had to add the line:

options snd-hda-intel model=hp-dv6 enable_msi=1

to the file sudo gedit /etc/modprobe.d/alsa-base.conf

share|improve this answer
    
Just to add a +1: I too have an hp pavilion dv6, had the same issue and the fix in this answer solved the problem. Thank you. –  jonnat Aug 23 '13 at 16:48

Yeah, I had the same problem on my HP dv6140us. I tried all manner of repairs, and decided on a workaround. I created a script, headphones-workaround.sh, containing the following:

#!/bin/bash

amixer set -c 1 Speaker unmute 70%

I saved the script in my home folder, made it executable (for newbie reference: chmod a+x headphones-workaround.sh) and created a clickable icon in my panel bar that links to the script (alt-rightclick in panel bar, choose Add To Panel, choose Custom Application Launcher, set name to whatever, and set Command to /home/your-user-name/headphones-workaround.sh).

Now, whenever I plug in my headphones I just click on the icon in my panel bar, and the headphones start working.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.