Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want a 2nd hard drive to mount at boot

I have this in /etc/fstab

UUID=7726e231-4373-451d-8588-930becd772c6 /home/server/common ext4 0 1

When starting I get an error, did I misconfigure the line?

share|improve this question
3  
What error do you get ? –  nixgadgets Apr 12 '13 at 3:22
add comment

2 Answers 2

up vote 0 down vote accepted

Look at the top of /etc/fstab. It should have a line like this:
# Device Mountpoint FStype **Options** Dump Pass#

Your mount line has these:

# Device              Mountpoint            FStype  Options    Dump    Pass#
UUID=7726...d772c6    /home/server/common   ext4                0       1

Notice the lacking value for the field options, which means that it gets parsed as:

# Device              Mountpoint            FStype  Options    Dump    Pass#
UUID=7726...d772c6    /home/server/common   ext4       0       1

And options 0 is invalid.

share|improve this answer
add comment

I would suggest the correct entry should be as follows:

UUID=7726e231-4373-451d-8588-930becd772c6 /home/server/common defaults ext4 0 1
share|improve this answer
    
I would be very useful to explain why your answer is correct - what is different, why the change and what it does. –  fossfreedom Apr 12 '13 at 10:41
    
the options go after the FStype so this is actually wrong. –  wlraider70 Apr 12 '13 at 19:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.