Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have just created a Ubuntu server and all is working well however at boot I receive the following error message which is causing problems. I am running Ubuntu Server 12.04

Here is the error any solution appreciated:

fsck from until-linux 2.20.1
mount: unkown filesystem type 'nosuid'
mountall: mount /dev/shm [284] terminated with status 32
mountall: Filesystem could not be mounted: /dev/shm
/dev/sda1: clean, 118954/24305664 files, 2148531/97219328 blocks
An error occurred while mounting /dev/shm
Press S to skip mounting or M for manual recovery

EDIT:

when you click M for manual recovery it appears the error is thrown here

[   15.216401] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro
[   16.014380] agpgart-ati 0000:00:00.0: unsupported Ati chipset [1002/5a331]
Filesystem check or mount failed

/etc/fstab/

# <file system> <mount point>   <type> <options>     <dump>  <pass>
# proc            /proc           proc   nodev,noexec,nosuid 0     0
# / was on /dev/sdal during installation
UUID=1ee5176b-957842d1-955f-de689a5baeb8 /         ext4  errors=remount-ro 0  1
# swap was on /dev/sda5 during installation
UDID=f5154c5b-6937-4fcc-8984-6129e74c35e9 none     swap  sw         0     0
tmpfs /dev/shm          defaults,boexec,nosuid    0   0

Its a real mess all system generated never been in here!

share|improve this question
    
I get the same darn thing sometimes... Only with ubuntu though, restored different images and... still only ubuntu –  Scott Goodgame Apr 11 '13 at 23:15
1  
Post your /etc/fstab file please. It most likely contains errors. –  Rinzwind Apr 12 '13 at 13:13
    
Ive added the /etc/fstab in the question ... I haven't added any of that code any help on tidying up greatly appreciated !! –  Henry Quekett Apr 12 '13 at 15:58
    
See my edit ;) The top line is correct and you can copy/paste it over the bottom line you have in your fstab :) –  Rinzwind Apr 13 '13 at 11:58
add comment

1 Answer 1

up vote 0 down vote accepted

nosuid is an option for mounting partitions/discs and options are the next column after the filesystem type.

/dev/shm is a temporary file storage filesystem. You probably added this yourself to /etc/fstab? Lines inside /etc/fstab need to be similar to this lay-out (the device names will probably be UUIDs):

# device name   mount point     fs-type      options           dump-freq pass-num
LABEL=/         /               ext4         defaults           1         1
/dev/sda6       swap            swap         defaults           0         0
none            /dev/pts        devpts       gid=5,mode=620     0         0
none            /proc           proc         defaults           0         0
none            /dev/shm        tmpfs        defaults           0         0

The last line is a possible similar line as you will need. Your /etc/fstab will have a line related to /dev/shm with nosuid in the fs-type column. Of course that is an invalid filesystem so Ubuntu can not mount the disc.

Change it to something similar as in my example by dropping to command line and

gksudo gedit /etc/fstab

and correct the line matching /dev/shm.


See the difference?

# device name   mount point     fs-type      options           dump-freq pass-num
none            /dev/shm        tmpfs        defaults           0         0

tmpfs           /dev/shm        defaults,boexec,nosuid    0     0

It is not even close to being correct ;)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.