Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running Xubuntu 12.10 in my laptop and I would like to monitor the CPU and HDD temperatures. I have installed lm-sensors, hddtemp and xfce4-sensors-plugin and added the widget into the XFCE panel. Now, when I login or manually run xfce4-sensors in terminal, I get the following notification:

"hddtemp" was not executed correctly, although it is executable. This is most probably due to the disks requiring root privileges to read their temperatures, and "hddtemp" not being setuid root.

An easy but dirty solution is to run "chmod u+s /usr/sbin/hddtemp" as root user and restart this plugin or its panel.

Calling "/usr/sbin/hddtemp -n -q /dev/sda" gave the following error:
/dev/sda: Permission denied

with a return value of 256. 

When this happens I do not have any option to show the HDD temperature on the panel. However, if I run gksudo xfce4-sensors and enter the password I get no error and can show the HDD temperature on the pannel if I want to.

Since root permissions are needed in order to run hddtemp and chmod u+s /usr/sbin/hddtemp is not recommended, what alternative do I have to run hddtemp from xfce4-sensors plugin automatically at login?

share|improve this question

I had the same Problem after upgrading to 13.04.

I would prefer a non-dirty solution also.

But This bugreport didn't provide any clean solution either

At least: The mentioned dirty solution worked for me:

set suid bit to hddtemp:

$ sudo chmod u+s /usr/sbin/hddtemp

$ xfce4-sensors

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.