Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

External hard disk (that requires 2 cable) was plugged into a Macbook Air, but my friend realised the cable doesn't stretch across the computer. So, it was plugged in for a while, powered up, but since it did not show up on the Mac, it never got dismounted/removed properly.

So, I went home and plugged it into my Windows 7 notebook, and suddenly the disk is asking me to reformat. I ran crystal disk management tool very recently, and the disk was/is in perfect health.

It doesn't read anything in Windows 7. But on my dual-boot WUBI-installed Ubuntu, I can see the folders on the disk: but they are all empty.

TestDisk Analysis shows:
Disk /dev/sdb - 500GB / 465 GiB - CHS 476940 64 32
        Partition                         Start       End             Size in Sectors

I don't quite know what to make of this results. Seems that there is no partition detected. And that is all there is. Any ideas, and what are my next steps towards recovering the lost partition and files?

Add Partition? Load Backup? Or, Enter to continue?

Thank you for any inputs!

share|improve this question
    
Have you tried plugging it back to your friend's MAC? –  Mitch Apr 11 '13 at 14:36
    
Hi Mitch. Not yet. The hard disk never actually registered/read on the disk, since the cable plugged in was for data-reading, and didn't have sufficient power to run properly. So the light went on according to him, and when the cable was too short, he just pulled it out. I will try that out. Thank you. –  alph Apr 11 '13 at 14:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.