Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i had my USB Modem ZTE working fine on Ubuntu, untill yesterday it won't connect anymore, yet it's detected as a modem in the connection manager but it won't connect, i tried it in Windows to make sure n it was working fine, and i have no idea how to troubleshoot the USB Modem!!! Thanks in advance.!

This's what i get trying to connect

share|improve this question

I had the same problem. I ran

sudo apt-get install udev-discover 

And restarted the system.

Hope this helps!!!

share|improve this answer
I can't do this coz i don't have internet access, i don't think this command will run probably!!!!! – Kaspro Apr 11 '13 at 15:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.