Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been running a virtualbox of Ubuntu Server for web development and have been getting along quite nicely. I decided to install Ubuntu Desktop via "sudo apt-get install ubuntu-desktop" so I can use Sublime Text until I get better with Vim. I have been SSH into my VM from PuTTY, and had my .bashrc set up how I liked it. Now that I have the GUI installed though, many bash commands aren't working and my shell settings are different.

For example, 'ls' now gives me this error:

ls: cannot access .color=auto: No such file or directory

I have verified that I am using /bin/bash via:

echo $SHELL

I believe it has something to do with using a non-login version of bash vs a login version over SSH, but I have tried sourcing the .bashrc and .profile to no avail. What am I doing wrong?

share|improve this question
up vote 4 down vote accepted

This smells like a problem with your aliases. You probably have something like

alias ls="ls -h .color=auto"

This is what I have:

alias ls='ls --color=auto'

After changing you need to reload the desktop!

share|improve this answer
This worked for me! Thanks. – josephndenton Apr 10 '13 at 20:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.