Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I connect my phone Xperia Tipo to my Ubuntu 12.04, the USB icon does not appear in a launcher.

lsusb gives me following results:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 8086:0189 Intel Corp. 
Bus 001 Device 004: ID 1bcf:2880 Sunplus Innovation Technology Inc. 
Bus 003 Device 003: ID 0fce:5170 Sony Ericsson Mobile Communications AB 

I installed Wammu and it does not see phone either:

Wammu is now searching for phone:
All finished, found 0 phones
No phone has been found!

On the phone I have debbugging turned on and it sees Ubuntu.

Can I ask for instruction step by step? I am a begginer on Ubuntu.

share|improve this question
    
did you set the phone to "mass storage mode"? –  Rinzwind Apr 10 '13 at 19:12
    
I have the same problem now: I have Ubuntu 12.04 and I try to connect it with Sony Xperia Z2 (which has Android 4.4). I have set Mass Storage Mode(MSC) setting but nothing happens when I connect cell phone to the laptop. Please advise what else I can do/ Thanks! –  user291858 Jun 9 '14 at 8:37
    
The 'Sony Ericsson Mobile Communications AB' is the Xperia, I think. –  gaoithe May 13 at 22:27

2 Answers 2

select USB Connection Mode,then choose : Mass Storage Mode(MSC)

take a look for this step by step solution

it worked for me

share|improve this answer
2  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Eliah Kagan Jul 3 '13 at 18:45

In your Xperia go to :

  1. Settings > Xperia > usb connectivity > usb connection mode
  2. Select Mass storage mode (MSC) > Press OK
  3. Then plug your phone with your SDCARD inside

Thats it.

share|improve this answer
    
this doesn't work for me using a Xperia Z (C6603) running stock Android 4.4.4. lsusb doesn't see the phone (confirmed the usb port and cable are working, tried alternate cable); the phone charges from this port and cable. Neither MSC nor MTM work. –  frumbert May 3 at 22:11
    
Some cables are power only - not data. A cable charging the phone does not necessarily mean it can be used to connect to computer. –  gaoithe May 13 at 22:29
    
@Frumbert do you still have a problem? Show the output of your lsusb? My Xperia wouldn't mount automatically - Ubuntu 14.04.1 - but manual mounting worked. More details here: android.stackexchange.com/questions/52932/… –  gaoithe May 13 at 22:32
    
@gaoithe: pastebin.com/LyAvzQti. Nothing works for me. Ubuntu fails to recognise the device electronically. Works well on Windows 7, works occasionally on MacOS 10.10. –  frumbert May 15 at 5:11
    
@Frumbert. Anything seen in 'dmesg' also 'lsusb' when you plug in? –  gaoithe May 15 at 8:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.