Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having a problem with Software Center being unresponsive. At the moment in the "progress" tab it's "searching" and it's stuck at canceling. Tried installing Dropbox earlier but that didn't go smoothly, as it hanged itself at "applying changes". Dropbox won't open at all.

I tried:

sudo apt-get update; sudo apt-get --purge --reinstall install software-center software-properties-common software-properties-gtk

I get this response:

E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

So it seems like software center is running all the time, and I can't modify it via terminal at all.

Help is much appreciated!

share|improve this question
    
Have you tried turning it off and on again? Based on this thread, which seems to be exactly the same problem you are having, restarting your computer and logging in without X (via terminal) should ensure Software Center doesn't hold a lock on /var/lib/dpkg and allow you to re-install it and dropbox. –  Alex Apr 10 '13 at 16:22
    
Yeah tried killing it via system monitor, didn't help. A shortcut to logging in without X? Tried ctrl + alt + f1. What should happen? Tried entering the command that solved the other threads problem. Got this message: dpkg: error: package name in specifier '-dropbox' is illegal: must start with an alphanumeric character. Any suggestions? First time using Ubuntu and Linux ! Cheers –  Abu264 Apr 10 '13 at 16:38
    
You should use the package name you are trying to remove instead of -dropbox. If the package name is dropbox then use just dropbox (without the -). Pressing ctrl+alt+F1 before logging in should throw you at console mode - I only suggested it because someone on that thread said Software Center was being initiated with the GUI, so in console mode you should be able to re-install it the way you were trying to. –  Alex Apr 10 '13 at 17:47
    
@Alex Tried now with only dropbox. Got this message this time: dpkg: warning: there's no installed package matching dropbox dpkg: dependency problems prevent removal of nautilus: nautilus-sendto depends on nautilus (>= 1:2.91). ubuntu-desktop depends on nautilus. gnome-session depends on nautilus. nautilus-share depends on nautilus (>= 2.10). dpkg: error processing nautilus (--remove): dependency problems - not removing Errors were encountered while processing: nautilus. So it says that I don't have dropbox installed, but when I go to software center it says that dropbox is installed. –  Abu264 Apr 11 '13 at 12:47
    
@Alex Trying to remove dropbox via software center won't work, SC just hangs itself. Any suggestions how to move forward? –  Abu264 Apr 11 '13 at 12:53
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.