Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get this error when I'm trying to do sudo mount -t ecryptfs folder1 folder2 in my home folder (encrypted by ubuntu) I tried the same command but folders at /tmp, it worked as expected.

The error message I got:

  ecryptfs_unlink_sigs
  ecryptfs_key_bytes=16
  ecryptfs_cipher=aes
  ecryptfs_sig=66cea2017ad38853
Error mounting eCryptfs: [-22] Invalid argument

In /var/log/syslog:

kernel: [  197.621331] Mount on filesystem of type eCryptfs explicitly disallowed due to known incompatibilities
mount.ecryptfs: Failed to perform eCryptfs mount: [Invalid argument]
kernel: [  197.659287] Reading sb failed; rc = [-22]
share|improve this question

1 Answer 1

You mentioned that your home folder is "encrypted by Ubuntu" -- it's actually encrypted using eCryptfs. Check the output of:

grep $HOME /proc/mounts

Nesting encrypted directories inside of encrypted directories is not supported with eCryptfs. Sorry.

Full disclosure: I'm one of the authors and current maintainers of eCryptfs.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.