Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got two Ubuntu laptops (both 10.10).
One is a new Maverick install and the other has been upgraded many times since 9.04.

On the latter, setting up a custom script hook in /etc/NetworkManager/dispatcher.d/ worked instantaneously.

However, on the older laptop, I can't get nm-dispatcher to get called, or at least to execute its hooks.

I've tried to run

NetworkManager --no-daemon -log-level=DEBUG

But there is no mention of nm-dispatcher.

How can I

  1. Have a look at the source (I looked into the git repo but could not find anything.

  2. find why the nm-dispatcher never gets called.

share|improve this question

1 Answer 1

You don't really need to look into the source code to fix this; the dispatcher runs the scripts in /etc/NetworkManager/dispatcher.d until it completes or until one of them returns with an error. This was the case on a few releases, because the initial dispatcher (01ifupdown) didn't understand the vpn-up and vpn-down (or hostname, even) states.

You'll be able to see what's happening from the logs in /var/log/syslog; they will contain a line such as:

Nov 5 21:38:57 chris-laptop nm-dispatcher.action: Script '/etc/NetworkManager/dispatcher.d/01ifupdown' exited with error status 1.

This particular issue has been fixed now; but if you're still having issues you should consider filing a bug, or the obvious stuff like verifying permissions (as in, whether the script is executable).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.