Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a file explorer window opened and is in the background of Chrome:

screenshot with file explorer behind chrome

However, when I click on the file explorer icon on the Launcher, it doesn't open/switch to the already opened window, but instead open a new one:

screenshot with new window opened in front of chrome

How can I just open/switch to the already-opened file explorer window?

Is this a known behaviour or is it a bug?

share|improve this question
1  
I have had this problem as well! It seems very random and I haven't been able to find any fixes! Hope someone figures this out soon! –  RPi_Awesomeness Dec 17 '13 at 1:44
    
Thanks god someone asked this. I was getting paranoid. Just to mention that this happens both if the already window is a normal Files window or if it is a copy file dialog etc. –  hakermania Dec 17 '13 at 3:12
    
Just did some searching and this came up: askubuntu.com/questions/324066/… (2nd answer) Might be worth trying (even though it seems to fail for that person.) Also askubuntu.com/questions/324066/… could be a duplicate... –  RPi_Awesomeness Dec 20 '13 at 2:24
    
Strange, I don't know if this helps, but whenever I hover my mouse over the Firefox icon it displays all open windows and lets me choose. > Edit: Spelling –  SomaComa Dec 26 '13 at 4:36
    
How about to switch thru open windows with Alt-Tab ? Not the expected answer but why bother, at max half a year and a brand new ubuntu will be released... –  Ice Dec 28 '13 at 21:37

1 Answer 1

You may have the "Open each folder in its own window" check box selected in the Behavior tab of File Management Preferences.

Select a folder
From the top menu bar, select Edit/Preferences
Behavior tab
Uncheck "Open each folder in its own window"

It would help to know which version of Ubuntu you are using; this answer is a guess. Edit your question with the output of this command from the terminal:

lsb_release -a
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.