Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to turn off two things in Firefox - it is re-opening every tab that was open when it was shutdown, and it always warns when I close multiple tabs.

I have altered both these behaviours in preferences (I set it to open just one defined home page on startup, and I unticked the multiple tab warning box), but Firefox is ignoring the changes.

I tried the reset Firefox button in the troubleshooting page, but it still misbehaves.

share|improve this question
    
Try with a new profile. askubuntu.com/q/32527/37006 –  Basharat Sial Apr 9 '13 at 23:44
    
Makes no difference. –  Jazz Apr 10 '13 at 0:34
    
Have you synced your Firefox? It's possible that some stuff from the "other account" overwrites the changes you're making. If you have synced accounts, try unsyncing. Otherwise, it's hard to understand why a new profile or a reset doesn't fix your issues. –  user25656 Apr 10 '13 at 2:55
    
I have never synced it with anything. –  Jazz Apr 10 '13 at 11:52
    
I have a theory that it is 2 separate issues/bugs. Firstly, it seems that it is only reopening tabs after a system shutdown (which normally is the only way I ever shut it down, as Firefox normally remains open for the entire session while I am logged in). My theory is that Ubuntu and Firefox are not talking properly at shutdown - and Firefox thinks it has crashed. The other problem, the warning on closing multiple tabs, happens when I right click on a tab and choose "Close other tabs". Is this just a bug that this action ignores the preference setting? –  Jazz Apr 10 '13 at 11:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.