Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have noticed that Kubuntu (I am using 12.04 version) doesn't use exactly the same repositories that Ubuntu. Or at least, that is what I think. For example, if I search for Steam on Muon Software Center or Muon Package Manager, I just can't find it; even if I use sudo apt-get install steam-launcher. But on Ubuntu I have no problem. Why?

That's why I think Ubuntu has some repositories that Kubuntu doesn't. In this case (I don't know if I'm right), how can I add this Ubuntu repositories?

Steam is only an example. There are many packages that I can't find on Kubuntu. Another example: Motorbike (a game) (https://apps.ubuntu.com/cat/applications/precise/motorbike/). sudo apt-get install motorbike doesn't work.

Regards.

share|improve this question

2 Answers 2

Kubuntu Wikipedia page: Every package in Kubuntu shares the same repositories as Ubuntu. However Steam and Motorbike aren't in the default ubuntu/kubuntu repositories. So you will have to enable the universe and multiverse repositories.

Managing Repositories in Kubuntu

pic1

Kubuntu uses KPackageKit for software management. To open it, click on your Kmenu, then open System Settings.

pic2

Next, select "Add and Remove Software"

pic3

Click the "Settings" button, then select "Edit Software Sources".

pic4

You will be prompted for your password in order to proceed

pic5

Next, go the the "Updates" tab. From here, you can enable/disable some of the official Ubuntu repositories and change your update settings. You should enable the universe and the multiverse repos.

Or, you could just type a line or two of commands and get the job done as follows:

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe multiverse"

then

sudo apt-get update

then

sudo apt-get upgrade

Kubuntu repository installation instruction page

share|improve this answer
    
Thanks for the reply. It's a bit different on Kubuntu 12.04. But I have the Universe and Multiverse repositories enabled, and I still can't find those packages. –  lesco Apr 12 '13 at 14:09
    
Did you get the repositories added? If the graphical interface looks different than posted, the command line will still work correctly. Make sure you do the sudo apt-get update from the command line to refresh your sources. An apt-get search PACKAGENAME should return information about the package you are looking to install. –  jjesse Apr 16 '13 at 14:50
    
I typed all the commands (adding the repo, update and upgrade), but nothing. "sudo apt-get search PACKAGENAME" doesn't work. Thanks. –  lesco Apr 17 '13 at 15:08

I had the same issue with kubuntu 12.04.3 LTS. I tried the terminal commands above but when I checked /etc/apt/sources.list the entries for universe and multiverse were incorrect.

The answer is to manually edit the file:

sudo nano /etc/apt/sources.list

Then add the following two lines:

deb http://archive.ubuntu.com/ubuntu/ precise universe multiverse
deb-src http://archive.ubuntu.com/ubuntu/ precise universe multiverse

Then save and exit. Finally:

sudo apt-get update
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.