Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

New user to Ubuntu here:

Just installed the new updates for 3.5.0-27, after reboot, my screen changes to 1024x768 and I don't see any launcher at all.

Can't access any settings besides the command line (Ctrl+Alt+T).

I tried to purge uninstall and reinstall nvidia-current, but still no avail.

I've tried (unity --reset-icons) brings up nothing but error messages related to GLX.

share|improve this question
add comment

2 Answers

Maybe this bug affecting nvidia users: https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1166765

temp fix is open a terminal and execute the following:

$ gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins $ shutdown -r now

if this fixes it ... maybe not permanent yet so keep this note handy.

share|improve this answer
add comment

+1 ... one of two monitors is dark and no unity launcher on the survivor. go back to 3.5.0-26 and everything is fine.

from Xorg log near the time of one of the failures ...

[ 18.624] (II) LoadModule: "nvidia" [ 18.624] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so [ 18.624] (II) Module nvidia: vendor="NVIDIA Corporation" [ 18.624] compiled for 4.0.2, module version = 1.0.0 [ 18.624] Module class: X.Org Video Driver [ 18.624] (II) UnloadModule: "nvidia" [ 18.624] (II) Unloading nvidia [ 18.624] (II) Failed to load module "nvidia" (already loaded, 32538) [ 18.624] (II) LoadModule: "nouveau" [ 18.624] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so [ 18.624] (II) Module nouveau: vendor="X.Org Foundation" [ 18.624] compiled for 1.13.0, module version = 1.0.2 [ 18.624] Module class: X.Org Video Driver [ 18.624] ABI class: X.Org Video Driver, version 13.0 [ 18.624] (II) UnloadModule: "nouveau" [ 18.624] (II) Unloading nouveau [ 18.624] (II) Failed to load module "nouveau" (already loaded, 32538) [ 18.624] (II) LoadModule: "nv" [ 18.625] (WW) Warning, couldn't open module nv [ 18.625] (II) UnloadModule: "nv" [ 18.625] (II) Unloading nv [ 18.625] (EE) Failed to load module "nv" (module does not exist, 0)

Perhaps more revealing, from syslog around the same time ...

Apr 15 20:39:12 hod kernel: [112066.363439] NVRM: API mismatch: the client has the version 304.88, but Apr 15 20:39:12 hod kernel: [112066.363439] NVRM: this kernel module has the version 304.84. Please Apr 15 20:39:12 hod kernel: [112066.363439] NVRM: make sure that this kernel module and all NVIDIA driver Apr 15 20:39:12 hod kernel: [112066.363439] NVRM: components have the same version.

google searches show this to be a common problem, but I saw no references to the current situation. Is it as simple as old driver tripped a histocompatibility interlock, and backed-off? An attempt to update nvidia-current says it is up-to-date.

So do I just stay on 3.5.0-26 and hope that the nvidia driver gets updated soon? Is there a more proactive solution to this problem? Am I on crack?

share|improve this answer
    
Is this an answer? If so I can't see it. This is not a forum and you need to provide a clear answer. If its a question then follow How to Ask –  Meer Borg Apr 16 '13 at 5:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.