Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently Installed 12.10 version and I loved it! But the there's something weird with Wallpapers. As long as I use a wallpaper from the /usr/share/backgrounds folder (I use the "appearance" dialog box), this wallpapers appears also on my welcome (login) screen. But when I try to use a wallpaper from my pictures folder (again using the "+" button from the appearance dialog box), my login screen has the standard ubuntu 12.10 wallpaper. Is there anything I can do to fix this?

Thanks in advance!

share|improve this question
    
Is the Pictures folder the default one i.e. located at /home/username/Pictures? –  green7 Apr 9 '13 at 20:07
    
Firstly, thanks for your reply! Secondly, yes! And i can also find the files through terminal. I tried "sudo cp /home/anthie/Pictures/Wallpapers/1.jpg /usr/share/backgrounds" but even though the image was copied it was corrupted and it never showed up in the Appearance dialog box :/ Any ideas? –  Anthie Georgiadi Apr 9 '13 at 21:37
1  
When you copy the picture to /usr/share/backgrounds you also need to change the permissions - read-write for owner and read-only for others. This can be accomplished by sudo chmod 644 filename. Also, is your home directory encrypted? Lastly, you need not thank everyone, this is just the way AskUbuntu works. –  green7 Apr 10 '13 at 4:54
    
Ok! :) Good evening, first of all :) Secondly, I really used the "sudo chmod 644" command you suggested and now the .jpg file can be opened with the Image Viewer from the /usr/share/backgrounds folder, but it's still not visible to the "Appearance Dialog Box" –  Anthie Georgiadi Apr 10 '13 at 18:59
1  
Yep. Your questions help others who face the same problem, so you really don't need to thank anyone or one thing can be that both thank each other which, ofcourse, doesn't seem much senseful. :) –  green7 Apr 10 '13 at 20:30

2 Answers 2

up vote 2 down vote accepted

When you copy the picture to /usr/share/backgrounds you also need to change the permissions - read-write for owner and read-only for others.

This can be accomplished by running the following command in a terminal:

sudo chmod 644 filename
share|improve this answer

Ubuntu tweak can do this:

enter image description here

My login now shows dragonlady.

share|improve this answer
    
I really thank you for your reply! :) I started thinking of using Ubuntu Tweak! :) But now I'm also curious! I mean if there is the option of auto change (depending on my desktop wallpaper), why should I use the Tweak Tool? But yes. It's my only option, if I don't find out why it happens, your answer saves me :) Thank you :) –  Anthie Georgiadi Apr 9 '13 at 21:35
    
I tried to add in a pix of my login but several attempts failed horribly :X Don't forget to upvote and accept it if acceptable ;) –  Rinzwind Apr 10 '13 at 6:37
    
Good evening! I do have news for Ubuntu-Tweak. I clicked on "set as desktop background" but I get a purple background :/ Is there any solution? –  Anthie Georgiadi Apr 10 '13 at 18:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.