Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

enter image description here

I have been getting this occasionally since I started using Ubuntu. Does anyone know a fix?

share|improve this question
1  
Do you have a Nvidia graphics card? if so, have you installed the non-propriety drivers? I suspect that you are suffering from a known problem.. –  yaron160 Oct 26 '13 at 14:21
    
I agree with @yaron160. I had lots of weird suspend/resume issue until I switched to the proprietary drivers. –  Seth Oct 29 '13 at 17:31
    
I have an AMD graphics card, and I've installed proprietary drivers for it. –  user137017 Oct 30 '13 at 3:47
    
@yaron160 It's obviously the WiFi card, not graphics causing the problem (nl80211 is the new netlink header). –  Donarsson Oct 30 '13 at 7:32

3 Answers 3

Having used any version of Ubuntu I had always resume/suspend issue. But it can depends on diffrenent kind of video card. So If you have hybrid nvidea + intel video card please do the next:

  1. Next you need switch in BIOS on only use Intel video card or read the topic about HybridGraphics
  2. Last thing is using small but working hack with switching graphic mode when laptop suspends and back after it resumes.
  3. To solve problem with brighness control you need use the manual (compizomania.blogspot.com/2014/06/ubuntu-1404linux-mint-17.html)

If you use not hybrid or optimal video card you are lucker and only one step that you need to do to install proprietary drivers (nvidia (www.binarytides.com/install-nvidia-drivers-ubuntu-14-04), fglrx (help.ubuntu.com/community/BinaryDriverHowto/AMD))

share|improve this answer

The problem is your WLAN card, it seems to sometimes not suspend/wake up properly (or not in time), which causes this error. I had a similar issue a while back, it fixed itself after some time (probably some minor update) and I haven't found any helpful documentation about this kind of error. But a good workaround for me was to disable WiFi (via the network indicator) before suspending an enable it after waking up, it should fix the problem.

share|improve this answer
    
Thanks, I'll try that. Also, I noticed that when I got a video opened up, it doesn't let me suspend. –  user137017 Oct 30 '13 at 15:07

I agree with Donarsson. The command iw does deal with wireless devices. Try (as suggested by Donarsson) disabling wireless before suspending. If resume works without issues, confirming the diagnosis, then you can check out the following page to automate unloading before suspend and loading after resume: https://wiki.archlinux.org/index.php/pm-utils#Standby.2Fsuspend_to_RAM

Basically, you need the line SUSPEND_MODULES="mod1 mod2 mod3..."to the file /etc/pm/config.d/modules where mod1, mod2, mod3... are the misbehaving modules to be unloaded/loaded.

The list of all modules (wireless and others) can be seen by running the command lsmod. I'm not completely sure how to find out which of these are to be added to SUSPEND_MODULES. Common wireless modules are ath5k, ath9k, iwlwifi and some realtek drivers beginning with r8.

share|improve this answer
    
Thanks for the suggestion. The resume working wouldn't really confirm the diagnosis. It works most of the time. –  user137017 Oct 30 '13 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.