Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
linux-image-server depends on linux-image-3.2.0-39-generic; however:
  Package linux-image-3.2.0-39-generic is not installed.
dpkg: error processing linux-image-server (--configure):
  dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: dependency problems prevent configuration of linux-server:
linux-server depends on linux-image-server (=; however:
  Package linux-image-server is not configured yet.
linux-server depends on linux-headers-server (=; however:
  Version of linux-headers-server on system is
dpkg: error processing linux-server (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.

Errors were encountered while processing:


E: Sub-process /usr/bin/dpkg returned an error code (1)

I don't know how to fix this issue. Plz help me. ><

share|improve this question
See if this helps: APT wedged by kernel version mismatch – Aditya Apr 9 '13 at 11:47
Thanks for your help. I reference link and link. And entering command dpkg --remove linux-server, dpkg --remove linux-image-generic linux-headers-generic. After removing, I use sudo apt-get -f install, and it works good. – Ethan Apr 9 '13 at 12:34
Your answer looks to be a bit different than the answers given in the link. Please post it as an answer to your own question. (When there is no other satisfactory answer and you've found the answer, we encourage this.) 2 days after posting it, you can accept your own answer (by clicking the gray check mark to the left of it). This will make clear that your problem is solved, and also help others searching for solutions to this or similar problems. Provide the links to those answers if it helps. – Aditya Apr 9 '13 at 13:39

This worked for me:

sudo dpkg --remove linux-server
sudo dpkg --remove linux-image-server linux-headers-server
# purge unused kernels, but could do more so your mileage may vary
sudo apt-get autoremove
sudo apt-get install linux-server linux-image-generic linux-headers-generic
share|improve this answer
Worked for me, thanks! However isn't it dangerous if you have a power outage and then your system is broken because no kernel is installed? – Konrad Höffner Mar 7 '14 at 9:46

For me the solution was different.

I used the command sudo aptitude, when the graphical menu appeared I used / to get a pop-up search field and find all the linux-header, linux-image, linux-server versions and removed all but the one currently used by pressing -.

To find the current kernel version I used uname -r.

Finally I installed a newer version of linux-{header, image, server} in the order specified by selecting them and pressing +.

To confirm the updates I used u.

At the end I rebooted and everything was fixed.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.