Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

From this morning the boot process on my laptop is no longer working. The only relevant change from yesterday (when all was working fine) has been a kernel update (from 3.2.0-39-generic to 3.2.0-40-generic).

When grub tries to boot the 3.2.0-40-generic kernel, I get only a black screen (the screen seems powered off).

After many tries and googling around, I found the following: if I change the CMDLINE_LINUX_DEFAULT grub parameter (inside /etc/default/grub) from the default value "quiet splash" to "nomodeset" the boot process works but the screen has a lower resolution than before (from 1600x900 to 800x600).

This is not happening with the previous kernel version (3.2.0-39-generic). Even with "quiet splash" enabled, all is working fine with the correct resolution.

An important note: my disk is fully encrypted (actually the setup is LVM + encryption). So when the boot works fine, after the grub selection screen I am asked to insert the passphrase for decrypting the whole file system.

Is there a way to fix this misbehaviour? I would like to avoid workarounds like using always an old kernel or using "nomodeset" as a default parameter.

Thank you in advance

share|improve this question
    
Any manually installed graphics drivers, ATI, Nvidia? –  mikewhatever Apr 9 '13 at 10:45
    
No,I didn't installed any graphic driver manually. Since everything was working fine out-of-the-box from the very beginning, I had no need to install any graphic driver –  pastoreerrante Apr 9 '13 at 11:04
    
This sounds like a bug and should be reported as such. How do I report a bug? –  gertvdijk Apr 9 '13 at 11:10
add comment

1 Answer

I was having that problem and after lots of time looking for what was causing t, i discovered that software manager wasn't updating initramfs leaving the boot state broken. But it only hapens with a few people. I don't know why.

Try to update the inirtramfs:

sudo update-initramfs -u

Tell-me if it worked.

EDIT: It seems its a bug, not in the update manager but in the kernel. https://bugs.launchpad.net/bugs/1167114

share|improve this answer
    
Same problem on 64 bit system; update-initramfs did not help. –  Art Swri Apr 19 '13 at 22:22
    
True. See this: bugs.launchpad.net/bugs/1167114 –  Celso Apr 26 '13 at 17:00
add comment

protected by Community Apr 10 '13 at 7:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.