Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having a problem connecting to internet on Ubuntu 12.10(just installed after giving up with 12.04 issues with graphics card) with a wireless and with a wired connection. I have looked into solving this problem myself but after much trouble and frustration I could use some help.

To my understanding I believe its because i have an AR8161 Ethernet controller and don't have the proper driver packages. This is where i'm having trouble, i don't know which packages to install or how to. I tried the download links people posted for people with a very similar issue. Either they don't work or i'm not installing them right. The way i tried to install them was i downloaded them on this computer and used a USB drive(key?) to transfer to the laptop without the internet connection and then opened them with the Ubuntu software center which led me to an error every time.

Any help will be greatly appreciated and any information you need from me i will post.

Thanks

share|improve this question
add comment

1 Answer 1

The drivers for AR8161 are not included in the Kernel yet, you have to install the drivers manually.

First check that the controller is unclaimed:

sudo lshw -C network

You should see something like:

  *-network UNCLAIMED              
       description: Ethernet interface
       product: AR8161 Gigabit Ethernet
       vendor: Atheros Communications Inc.

To install the drivers for the AR8161 just execute:

sudo apt-get install build-essential linux-headers-generic linux-headers-`uname -r`
wget -O- http://linuxwireless.org/download/compat-wireless-2.6/compat-wireless-2012-07-03-pc.tar.bz2 | tar -xj
cd compat-wireless-2012-07-03-pc
./scripts/driver-select alx
make
sudo make install
share|improve this answer
    
Yes its UNCLAIMED. I'm a newbie so bare with me, do i type all that in at once or line by line and that will work even though i can't connect to the internet? –  Trublet Apr 9 '13 at 18:26
    
First check if the controller is still unclaimed. If not, check if you have an IP assigned by running: ifconfig -a –  ialonso Apr 10 '13 at 8:50
    
Its Unclaimed and their is nothing saying ip address, but the inet address shows 127.0.0.1 –  Trublet Apr 11 '13 at 6:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.