Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently changed my system language to Tamil (a language used in India) from English. While I was enjoying Ubuntu in Tamil, my favorite editor vim has run into an issue because of the system language change, it seems.

enter image description here

How can I fix this?

share|improve this question
    
Try :set encoding=utf-8 –  Basharat Sialvi Apr 9 '13 at 3:10
add comment

1 Answer 1

I would try running this in from the vim terminal while the offending file is opening

:set fileencodings=ucs-bom,utf-8,sjis

and if that doesn't work, you should be able to find what you need here Vim User Manual Language Encoding

What happens if you run vim from the terminal and not gvim?

share|improve this answer
    
1) I tried setting that, it didnt help. Moreover, I wasnt even able to confirm the result of that command, since I couldnt read anything. 2) I tried to open vim from the terminal and it works like a charm. This is the output of :langauge Current language: "LC_CTYPE=ta_IN.UTF-8;LC_NUMERIC=C;LC_TIME=ta_IN.UTF-8;LC_COLLATE=ta_IN.UTF-8;LC‌​_MONETARY=ta_IN.UTF-8;LC_MESSAGES=ta_IN.UTF-8;LC_PAPER=ta_IN.UTF-8;LC_NAME=ta_I N.UTF-8;LC_ADDRESS=ta_IN.UTF-8;LC_TELEPHONE=ta_IN.UTF-8;LC_MEASUREMENT=ta_IN.UTF‌​-8;LC_IDENTIFICATION=ta_IN.UTF-8" 3) gvim didnot work both from command line and direct invocation –  thefourtheye Apr 9 '13 at 7:12
    
@thefourtheye maybe your gvim needs to be re-installed. It doesn't seem to be a problem with Vim just Gvim. –  dustin Apr 9 '13 at 14:45
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.