Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

am using the sendmail to send an email and configure it as the following :

define(`RELAY_MAILER_ARGS', `TCP $h 587')
FEATURE(`authinfo',`hash /etc/mail/authinfo')dnl


AuthInfo:smtp-server "" "P:password" "M:PLAIN"

after that i run the following command :
$ m4 >
$ makemap hash authinfo < authinfo
$ /etc/init.d/sendmail restart

and test it with :
/usr/sbin/sendmail -v < body.txt

but still cant receive any email ?? and i got the following error

Deferred: Name server:smtp-server-name: host name lookup failure <br>

i tried i can ping to the smtp server , and i run the command dig smpt-server-name
i cant see any thing wrong ... why i got this message and cant revise an email.

share|improve this question
up vote 0 down vote accepted



It should turn off lookups for MX records. If it does not help try Ipv4 address inside square brackets.

share|improve this answer
you are right ... and the ISP was block the smtp port :) ... – moata_u Apr 9 '13 at 17:07

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.