Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ sudo apt-get install wine
[sudo] password for hergul: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine : Depends: wine1.4 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

and:

$ sudo apt-get install wine wine1.4
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.4 : Depends: wine1.4-i386 (= 1.4-0ubuntu4.1)
E: Unable to correct problems, you have held broken packages.

and:

$ sudo apt-get install wine wine1.4 wine1.4-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.4-i386:i386 : Depends: libglib2.0-0:i386 (>= 2.16.0) but it is not going to be installed
                     Depends: libgphoto2-2:i386 (>= 2.4.10.1) but it is not going to be installed
                     Depends: libgstreamer-plugins-base0.10-0:i386 (>= 0.10.22) but it is not going to be installed
                     Depends: libgstreamer0.10-0:i386 (>= 0.10.26) but it is not going to be installed
                     Recommends: gettext:i386 but it is not going to be installed
                     Recommends: libfontconfig1:i386 but it is not going to be installed or
                                 libfontconfig:i386
                     Recommends: libsane:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

and

$ sudo apt-get autoremove 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

and

$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.

I have tried to install with synaptic and aptitude install but it did not.

Ubuntu 12.04 x64

share|improve this question
add comment

1 Answer

It seems to be due to some dependencies on 32 bit packages, try running sudo apt-get install ia32-libs and then attempting the install again.

share|improve this answer
    
$ sudo apt-get install ia32-libs Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ia32-libs : Depends: ia32-libs-multiarch E: Unable to correct problems, you have held broken packages. –  Mustafa Hergül Apr 8 '13 at 18:32
    
That doesn't sound good... try sudo apt-get install ia32-libs-multiarch and see what happens. –  handuel Apr 8 '13 at 18:33
    
and: sudo apt-get install ia32-libs-multiarch : The following packages have unmet dependencies: ia32-libs-multiarch:i386 : Depends: libgettextpo0:i386 but it is not going to be installed Depends: gstreamer0.10-plugins-base:i386 but it is not going to be installed Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed Depends: gtk2-engines:i386 but it is not going to be installed Depends: gtk2-engines-murrine:i386 ......................... –  Mustafa Hergül Apr 8 '13 at 18:34
    
Depends: libgettextpo0:i386 but it is not going to be installed Depends: gstreamer0.10-plugins-base:i386 but it is not going to be installed Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed Depends: gtk2-engines:i386 but it is not going to be installed Depends: gtk2-engines-murrine:i386 but it is not going to be installed Depends: gtk2-engines-pixbuf:i386 but it is not going to be installed Depends: gtk2-engines-oxygen:i386 but it is not going to be installed Depends: gvfs:i386 but it is not going to be installed ......... –  Mustafa Hergül Apr 8 '13 at 18:37
    
i tried this solution:askubuntu.com/questions/153907/… but it did not –  Mustafa Hergül Apr 8 '13 at 20:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.