Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I set minimized apps' names on taskbar (they call it taskmanager widget in kde I believe, that panel at the bottom) NOT to be gray? Ie where can I change its font, in system settings I can change colors of inactive titlebars, but there is nothing for changing taskbar colors.

I once got an answer (Minimize windows without them going black and white) however it is NOT the answer for this question. It only allowed me to change icons color, not the font color.

The names in gray are unreadable on most wallpapers on my screen.

share|improve this question

2 Answers 2

up vote 4 down vote accepted
+100

KDE Plasma Themes

The KDE TechBase : http://techbase.kde.org/Welcome_to_KDE_TechBase

The KDE taskbar (panel) is a plasma object so its configuration is through the KDE plasma theme configuration - the Development/Tutorials/Plasma/Theme is tellling:

http://techbase.kde.org/Development/Tutorials/Plasma/Theme -> http://techbase.kde.org/Development/Tutorials/Plasma/Theme#Theme_Colors

Theme Colors

You can provide a plasma color scheme that will allow text, selected backgrounds and other items to blend well with your theme by supplying a colors file in your theme folder. See the colors file in the default theme for an example.

If the colors file is omitted, plasma will take on the current KDE system colors. Note: Theme SVGs will not be colorized unless they contain the 'hint-apply-color-scheme' element.)

More can be found from the Development/Tutorials/Plasma/ThemeDetails

http://techbase.kde.org/Development/Tutorials/Plasma/ThemeDetails -> http://techbase.kde.org/Development/Tutorials/Plasma/ThemeDetails#Colors

From the KDE mailing list - [kde] settings for font colors

http://linux.derkeiler.com/Mailing-Lists/KDE/2010-03/msg00011.html

The desktop, aka plasma, has its own themes. However, in a couple places, they seem to interact with the normal kde colors as well. Well either that or the themes I run don't have a couple things set too well. This can be bad if like me you have a strong "reverse color scheme" (that is, light text on a dark background) preference, as that's uncommon and the assumption would be dark text on a light background.

Unfortunately, unlike kde, where most of the colors are set specifically, with plasma one has to choose a theme -- altho individual components (, general color scheme, panel background, desktop widget background, analog clock, etc) can be set to different themes if desired. Editing individual elements within a component, however, requires editing the text-based config files themselves, unfortunately...

KDE Brainstorm

http://forum.kde.org/viewforum.php?f=83

A wish: http://forum.kde.org/viewtopic.php?f=113&t=101989

I would

I would use the non-transparent panel.

Opaque panel

Background

http://techbase.kde.org/Development/Tutorials/Plasma/ThemeDetails#.22Opaque.22_folder

"Opaque" folder

In the folder share/apps/desktoptheme/opaque the same hierarchy can be found: when compositing is disabled files in this folder are preferred over the corresponding ones listed above...

But you could use the opaque plasma object with the compositing.

Another theme

The KDE System Settings > Workspace Appearance > Desktop Theme has the "Get New Themes". There are themes with the opaque panels - the Aya seems to be one of them.

Mixing theme components

KDE System Settings > Workspace Appearance > Desktop Theme -> Details tab. Pick the opaque panel from another plasma theme. Note the panel background is not working at here. Maybe this is working there.

How it should work - tested with the KDE 4.10.2 - Air (default) desktop theme with the opaque Air theme panel

KDE System Settings > Workspace Appearance > Desktop Theme -> Details tab; Panel Background: File=/usr/share/kde4/apps/desktoptheme/default/opaque/widgets/panel-background.svgz -> Apply

enter image description here

Now the selected theme with the customize opaque panel background should be copied to the ~/.kde/share/apps/desktoptheme/.customized/.

enter image description here

BUT this doesn't seem to work with the panel background. I tried this with the "Translucent Background" (for the other plasmoids) - it was working.

How to get the customized panel background to work (working at here)

1) Set the plasma desktop theme off from the "Customized"

2) Copy panel-background.svgz from the ~/.kde/share/apps/desktoptheme/.customized/opaque/widgets/ to the ~/.kde/share/apps/desktoptheme/.customized/translucent/widgets/

enter image description here

3) Remove/clean the plasma theme cache from the /var/tmp/kdecache-[username] (same as ~/.kde/cache-[hostname]). The KDE is caching things like a mad - and using the information from the cache.

enter image description here

4) Log out - log in (or kill the plasma desktop and restart the plasma-desktop)

The panel background should be opaque - at here it is.

enter image description here

enter image description here

A PNG image as the panel background: http://forum.kde.org/viewtopic.php?f=113&t=101989 -> http://www.kubuntuforums.net/showthread.php?56120-Customize-plasma-desktop-theme

share|improve this answer
    
Could you tell me how can I exactly set panel to be non-transparent? I know that I can achieve it by disabling all effects in settings, but that disables all animations etc so I don't want it. I just want taskbar to be non-transparent –  user1873947 Apr 18 '13 at 21:45

Making a little search I found out that others have the same problem as you and they don't get a solution. The best I got is a recommendation to the package systemsettings.

So, had you tried System Settings > Application Appearance ? There are options to change Fonts, Colors and Style, maybe it can solve your problem.

If it doesn't, then the ways to accomplish what you want are a direct code editing (in case you want to improve KDE yourself releasing a patch for that, as a contributor developer) or asking them the feature. You should file a bug in LaunchPad.

share|improve this answer
    
unfortunately, I can change there almost everything but that... Maybe I should add feature request to KDE, because it's strange that I can change the icon color and I can't change the font color... –  user1873947 Apr 17 '13 at 16:24
    
Yes, I see that the only way for you to get that would be a manual code editing or a feature request. You can also file a bug in LaunchPad. I edited my answer to cover this situation now. –  Rodrigo Martins Apr 17 '13 at 21:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.