Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Transmission has this incredibly aggravating tendency to not stop when I click the exit button.

Instead, it minimizes. When I click to exit, I want the program to cease immediately, but I can't figure out how to do so via the preference menus. Is there even a way to do this?

share|improve this question
Same as this?… – fossfreedom Apr 8 '13 at 13:41
I did not see that question, but what about for transmission? – acolyte Apr 8 '13 at 13:46
sudo /etc/init.d/transmission-daemon stop ? >:) – Rinzwind Apr 8 '13 at 13:50
also could be this bug: – Rinzwind Apr 8 '13 at 13:51
@Rinzwind what will stopping that do? Will I need to run that every time i want to close transmission? – acolyte Apr 8 '13 at 13:59
up vote 2 down vote accepted


Disable the checkbox beside Show Transmission icon in the notification area. You would find this option under Edit Menu → PreferencesDesktop Tab.


share|improve this answer
So is it possible to disable this pointless "intelligent" quitting? If i click "exit", I want the thing to stop, not keep going. If i anted it to continue running, I wouldn't have clicked "exit". Thanks for the Transmission info, though. I'll try that out when I get home tonight. – acolyte Apr 8 '13 at 14:08
Not sure if it is possible to quit Rhythmbox in the way you desire (although I think the way it decides to quit or not makes much more sense). If I were in your position and desired the functionality to actually close the application I would have used another music application - vlc, banshee, etc and made them the default for music. – Aditya Apr 8 '13 at 14:14

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.