Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am having a problem with Google Chrome on Ubuntu 12.10 64.

On about 20-30% of web sites the page comes up and starts "flickering". It seems like there is a different or partial rendering of the page in a different buffer and several times per second the page swaps between the two screen buffers, causing a kind of epileptic flashing of different images.

I can also not scroll the page when it is in this flickering state, any attempt to scroll causes the page to go to the top again on the next flicker.

I am using the fglrx driver if that means something:

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7900 Series
OpenGL version string: 4.2.12002 Compatibility Profile Context 8.961

Chrome version is:

Google Chrome   25.0.1364.172 (Official Build 187217) 

Any ideas?

share|improve this question
I have this problem on Ubuntu 14.04 as well. I have noticed that closing programs (especially those that use the gpu) sometimes eliminate the problem. – stvn66 Oct 13 at 3:43

4 Answers 4

This is a known issue with ATI/AMD graphics card and compositing.

For some people starting Chrome with --blacklist-accelerated-compositing parameter brings some help. Others report that --disable-gpu parameter helps.


As far as i understand, the only real fix is to switch to Nvidia or Intel GPU. Adding parameters like the ones above cost performance and disable certain features which require compositing. To check your Chrome's state of GPU affairs visit chrome://gpu

share|improve this answer
I think that made the problem worse for me. – mpen Oct 24 '13 at 17:09

You might try starting chrome with --disable-gpu.


share|improve this answer
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. – g_p Dec 20 '14 at 13:22
I thought "starting chrome with --disable-gpu" would be the essential part. The link would not even be necessary to help someone (it was in fact added only for reference). – jox Dec 21 '14 at 17:06

Revisiting this page after a month, the problem was that hardware acceleration wasn't enabled. This is apparent on HTML5 videos too!

Go to chrome://flags

Look for “Override Software Rendering List”, i.e. enabling GPU acceleration on unsupported hardware and enable it. Restart Chrome (close the background process if you have that running on the top of the bar) and see if it works for you.

Read more here.

share|improve this answer

This solution very similar to @jox's answer (turning off GPU support fixed this issue for me), but if anyone is curious how to do this, you can simply go to Settings -> "Show advanced settings..." -> System and uncheck "Use hardware acceleration when available"

I'm using Ubuntu 15.04 and fglrx from the Ubuntu repos on Chromium 45.0.2454.85.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.