Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 10.10 and have problem with proprietary nvidia driver for my GeForce GTS 250. I have issue with poor Compiz performance. And there is also open-source "noueau" driver.

  1. Proprietary: I tried many versions but neither works fast on desktop. This means 30 FPS without heavy effects. Currently I am using version 270.18. Even normal desktop use feels bad (moving windows) In games (and 3D benchmark) it is really good! (Unigine Heaven works good!)
  2. Open-source "nouveau": Very fast on desktop with heavy effects (blur, ...). I have 300 FPS and more, even in Expo mode. Games were good but not as good as prop. And driver causes xorg to crash even the latest (ppa:xorg-edgers/nouveau), so I switched back to proprietary.

I also have computer with Ubuntu 10.04, GeForce 8600GT and drivers around 185.x and Compiz works great there.

There is similar question Nvidia proprietary driver performance in 10.10

Which version of nvidia (prop) driver is fast in Compiz in Ubuntu 10.10? How do you install a specific version of nvidia driver? Is it the case that each newer driver works slower on compiz?

edit: I tested 8600GT and GTS250 on Ubuntu 10.04 under 197.x.x drivers. Performance in Compiz and games are great! So Ubuntu 10.10 with 260.x.x or newer driver is not good for Compiz?

share|improve this question
    
Do you have direct rendering? glxinfo | grep direct –  shellholic Feb 24 '11 at 16:08
    
direct rendering: Yes –  gsedej Feb 24 '11 at 17:24
    
Do you still have the problem. Have you found how to solved the problem or considered accepting an answer that solves your problem (if any)? –  Luis Alvarado Dec 5 '11 at 18:56
add comment

2 Answers

I would try 260.19.36 or 260.19.29.

The 270 driver line is VERY beta right now. I'd steer clear. I currently use 290.19.36 in Ubuntu 10.04 -- sorry can't upgrade right now to 10.10 for comparison.

FWIW, I use this link.

share|improve this answer
    
Note: those are the drivers for the amd64 architecture, so you shouldn't install them if you're running 32-bit Ubuntu. –  Firefeather Mar 4 '11 at 20:53
    
Yeah, sorry - I default to x64 now. Here's the x86 link –  M. Tibbits Mar 4 '11 at 22:25
    
Thanks for answer. I removed x-updates ppa and installed default 10.10 driver for my x64 system. But Compiz is still really slow. Glxinfo says NVIDIA 260.19.06. I don't want to break something at the moment sice GTS 250 computer is my primary work computer. Might be some problems with x64 build of driver? –  gsedej Mar 24 '11 at 21:08
    
FYI, nvidia has updated the 270 drivers twice now. Have you had a chance to try the 270.35 driver yet? I've now switched and under certain settings it appears much faster -- though I mostly do gpgpu shtuff. –  M. Tibbits Mar 27 '11 at 16:38
add comment

Here's what I did and it seems to fix things. One of the options when installing the driver from the nvidia .run file (version 270.26) is whether to install 32bit compatibility libraries. You need to select NO on this if you have a 64 bit system. When I disabled the driver from the repositories and reinstalled this driver without adding 32 bit compatibility support, the performance problems disappeared. (Note if you're doing it this way, you also need to blacklist the noveau kernel module.)

share|improve this answer
    
Also, the other thing I did (not sure it helped, I did it at the same time) was make sure the VSync settings matched up between KDE and the nvidia driver. –  hoytak Mar 21 '11 at 21:41
    
Meep. Please don't recommend installing the nvidia drivers from the .run file. This breaks a lot of assumptions that Ubuntu software makes, and it can be difficult to get back to a supportable configuration. There should (eventually) be a couple of different nvidia drivers available from Hardware Drivers. At the moment, though, only nvidia-current supports our X server. –  RAOF Mar 22 '11 at 2:03
    
I will try this solution when I have time. Now I don't want to risk to break Xorg server. –  gsedej Mar 24 '11 at 21:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.