Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When i trying to install some CMS it couldn't create config files because apache user is different. On OS X i solved this problem by adding user and group inapache2.conf, but on Ubuntu i can't figure out what group i should add.

share|improve this question
    
the group is named www-data. –  Salem Apr 7 '13 at 22:36
    
What Salem said. But, the full error message is useful you know. What's the exact error message you are getting? –  Thomas W. Apr 7 '13 at 22:36
    
@TheLordofTime no errors is provided. I just want to change current group to my users –  Kirix Apr 8 '13 at 5:33

1 Answer 1

In Ubuntu and Debian, the user Apache runs as by default is www-data:www-data. You should not change this so that it runs as a normal user, www-data is a special system account.

share|improve this answer
    
i know, but i need to change it to the current user. –  Kirix Apr 8 '13 at 5:32
    
@Kirix Why not just have your folders you have the files in group owned by www-data such that it shows as user:www-data, thereby giving www-data read/write as is needed? It's not a good idea to have a web server running as non www-data for most deployments. –  Thomas W. Apr 8 '13 at 6:55
2  
You should not run the apache2 under the user which can modify the scripts. It's much better just to allow the CMS to write it's config file, f.e. by creating config file or config directory and setting the ownership to that file just for the moment of config file creation. –  oerdnj Apr 8 '13 at 14:35
    
True, that is also acceptable. –  Thomas W. Apr 8 '13 at 14:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.