Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a macbook pro retina and I have apple, refit, windows 7 and ubuntu 12.10 installed.

When I first installed Ubuntu I got the error missing operating system. But windows 7 and mac was booting/working fine.

So I made a partition for the boot loader (instead of using the partition I use for ubuntu), and when I told refit to boot Linux, it would just freeze on the boot icon. But windows 7 and mac booted/worked fine.

Then when I chose Linux it would boot windows 7 instead. That has stopped, and now Linux AND windows 7 gets stuck on the boot icon!

What is happening?! This is my first time with ubuntu and refit, so I could really use some help. Thanks

share|improve this question
    
Fixed it. I deleted reFIT and used refind instead and everything works FINALLY! –  user147614 Apr 8 '13 at 5:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.