Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm behind a router with my other computer. When I try pinging my external IP or the host resolving to it, I don't get host unreachable or a timeout, there just isn't any output at all. It looks like this:

username@username:~$ ping X.X.X.X
PING X.X.X.X (X.X.X.X) 56(84) bytes of data.

I'm able to ping any computer in my LAN, my default gateway, the broadcast and any alive host from the WWW. My internal LAN Card is Atheros GbE LAN chip.

So far I have tried and understood the following:

  1. I'm using Xubuntu 13.04 Raring and my PC has a dual boot with it and Windows 7. In Windows I don't face such problems, everything seems OK, so it's not my router or computer.

  2. In Linux I use one single iptables rule for protecting a server I'm running and nothing else, so it's not a firewall issue.

  3. I connected my laptop to my neighbour's Wi-Fi (same ISP, different router brands) and booted a Live USB with my current OS (Xubuntu 13.04) - everything worked, pings to the external IP were successful.

  4. Enabled my own Wi-Fi and connected to it with the laptop (same OS). Tried pinging the IP and the host resolving to it and it worked - another confirmation that it isn't a router problem.

  5. Tried fping on my PC and it shows "X.X.X.X is unreachable" (where X.X.X.X is my external IP).

  6. My other PC uses Windows XP and pings are successful there.

  7. I connected an external PCI LAN card (Realtek) to my PC and tried pinging in both OS and Live USB and it was unsuccessful.

Can somebody please explain what the problem might be and suggest a solution? Thanks in advance.

To address the question's gertvdijk asked:

Well, DMZ from NAT is activated for my PC's LAN address in the router's settings and some ports (27000-27050) are forwarded. Even if the NAT Loopback is the solution, my 'hi-tech' router doesn't have such a feature. I'm going to try to enable DMZ for the laptop's IP and try to ping my external IP from the Live USB. I'm also going to try with Ubuntu 10.10 Live CD later and will post the outcome...

By the way, I have a Canyon CNP-WF514 and as far as I remember when I had Canyon CNP-BR1 this wasn't an issue. I'm not entirely sure about the pinging but back then I was able to connect to my server from my external IP and now I'm not (only from my local one).

share|improve this question
1  
Assuming you're using NAT on your router, you usually can't reach the WAN address from the LAN side. Such a feature you're expecting is called NAT Loopback and is rarely activated. My best guess is that Windows tries to determine the IPv4 external address in a way and just pings your gateway on the LAN side. –  gertvdijk Apr 7 '13 at 18:13
1  
katokotka: Right now you have two separate accounts, and you're not using the one that you used to post the question. They're both unregistered. If you register an account, you can use the contact us link at the bottom of the page to request your unregistered account(s) be merged with your new registered account. Then you'll be able to more easily edit your posts, and you'll be able to post comments on your posts. @gertvdijk I've added what appears to be the OP's response to your comment, to the question. You, katokotka, or anyone should feel free to edit further to present the info better. –  Eliah Kagan Apr 7 '13 at 19:26
    
Is this causing you an issue or are you just curious? If you are trying to check for a service of port you could try canyouseeme.org. Otherwise I think gert says all there is to say. –  wlraider70 Apr 12 '13 at 20:29
add comment

1 Answer

First of all: check if you have proper configuration: - try to ping your gateway, is it work? If no check your gateway IP. - try to ping 8.8.8.8 (Google's DNS) - is it work? If no, check you routing using one of:

mtr 8.8.8.8

or

tracepath -n 8.8.8.8

and check at which hop the routing stops.

Regarding DNS namees: please add to the /etc/network/interfaces lines:

dns-nameservers Your_DNS_IP_address

You can check website ping by using WhoisXY.com

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.