Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed VirtualBox on Windows host with Ubuntu (actually Xubuntu) guest. after adding 3 more hard drives (virtual hard drives), I ran ls –l /dev/sd* and there were 3 more drives:

dev/sdb
dev/sdc
dev/sdd

then I ran this code to mount them:
sudo mkfs –t ext4 /dev/sdb
sudo mount –t ext4 /dev/sdb /home/hershalle/sd2

sudo mkfs –t ext4 /dev/sdc
sudo mount –t ext4 /dev/sdc /home/hershalle/sd3

sudo mkfs –t ext4 /dev/sdd
sudo mount –t ext4 /dev/sdd /home/hershalle/sd4

the next time I tried to log in, I got this message:

FATAL: No bootable medium found! System halted.

what did I do wrong? and How do I fix it?

thanks!

share|improve this question
    
Are you sure you didn't accidentally reformat /dev/sda? Can you boot a liveCD iso and mount /dev/sda and verify all the files are there? If you remove those drives does it boot again? Could you provide a picture of your "Storage" tab in VM Settings? –  jmathew Oct 15 '13 at 20:30
add comment

1 Answer

Open the virtual machine settings, check the boot order (in the "System" tab) and check that there is a live CD or bootable virtual disk (in the "Storage" tab).

Chances are you have used a Live CD, which ejected itself from the virtual drive on shutdown (as it would typically do on real hardware).

The message has nothing to do with the mounts, which are reset when Linux is shut down.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.