Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have found that using desktop effects in Ubuntu versions later than 8.10 causes the desktop to freeze after a few seconds on my PC. the command lspci -nn gave the following

00:02.0 VGA compatible controller [0300]: Intel Corporation 82945G/GZ Integrated Graphics Controller [8086:2772] (rev 02)

and with lspci -k I have

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)
Kernel driver in use: i915
Kernel modules: i915

The intel graphics cards seems to have some performence issues with xorg driver. However I have not noticed any freeze in Ubuntu 8.10.

There are some workarounds at https://wiki.ubuntu.com/X/Bugs/Lucidi8xxFreezes to make them work. But I can't find out what workaround should I do with my graphics controller. I have tried workaround F but it did not help.

can anyone help me find a workaround for my graphics card? and is it actually possible to use desktop effect in this graphics card ?

share|improve this question

closed as off topic by Marco Ceppi Feb 4 '12 at 21:07

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3  
What Ubuntu version you are using now? 10.04, 10.10? Problem still persists? –  Olli Feb 24 '11 at 12:49
    
I am using 10.10. I have also used 10.04. the problem still persists ! –  munir Feb 25 '11 at 9:46
    
is there anybody who can help ? I am waiting for two days for any answer... –  munir Feb 27 '11 at 11:27
    
This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Feb 4 '12 at 20:04

1 Answer 1

Disable the desktop effects:

We have three computers with the same chipset and the very same problem at work.

20 PCs, 3 of them with the intel 945 chipset... the three of them have issues. They constantly freeze. We tried to boot in Ubuntu Classic, but it doesn't change anything.

Just stick to 10.04 and disable the desktop effects.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.