Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set a DHCP server on 12.04. I installed:

sudo apt-get install isc-dhcp-server

My configuration files look like this:




auto lo
iface lo inet loopback


ddns-update-style none;
default-lease-time 600;
max-lease-time 7200;
log-facility local7;

subnet netmask
    range             ;
    option subnet-mask;
    option broadcast-address;
    option routers    ;
    default-lease-time          100000;
    max-lease-time              100000;

When I run sudo service isc-dhcp-server restart I get:

stop: Unknown instance: 
isc-dhcp-server start/running, process 15384

After this if I run sudo service isc-dhcp-server status it shows that its stopped:

isc-dhcp-server stop/waiting

What am I doing wrong here?

share|improve this question
what is the output of your /var/log/syslog, after you attempt to start the dchp server – tomodachi Aug 9 '13 at 12:04
sudo nano /etc/network/interfaces

 auto lo
 iface lo inet loopback

auto eth0
   iface eth0 inet static

your server must have a static IP. that ip must not be in your dhcp IP range Restart networking deamons and restart dhcp as well

 sudo /etc/init.d/networking restart

 sudo /etc/init.d/isc-dhcp-server restart
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.