Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log in to my Ubuntu system several applications that I added to startup list (by using System->Preferences->StartUp Application) start automatically.

Last times I am seeing that among those startup applications there is also another one called "Konqueror" (which is a browser and browse me automatically http://unix.stackexchange.com/users/4458/bakhtiyor) which starts automatically. But I didn't add this application to startup list. I looked for every place that I knew to see why it was loading automatically but I could not find it.

Could anybody help me to find out how that application is starting up automatically when a session starts please?

Note that I don't have root permission in my system, because it is in my working place. I am using Ubuntu Desktop and GNOME.

Thank you.

share|improve this question
    
Konqueror is KDE - are you using Kubuntu? Or are you using both GNOME/KDE? –  mathepic Feb 24 '11 at 11:55
    
you say you added the application to startup and it autostarts ? That is what it is supposed to do, isn't it? Remove those from startup applications or Did I understand your question wrong ? –  sagarchalise Feb 24 '11 at 11:56
    
@mathepic. I am using Ubuntu Desktop and GNOME. –  Bakhtiyor Feb 24 '11 at 12:07
    
@sagarchalise. But I didn't add Konqueror to startup list. This is the problem. –  Bakhtiyor Feb 24 '11 at 12:08
    
is kde set to remember your session? –  Allan Feb 24 '11 at 12:16
show 3 more comments

2 Answers

up vote 2 down vote accepted

Go to System>Preferences>Startup apps, then on the Options tab uncheck the "Automatically remember...." checkbox.

share|improve this answer
    
It is currently unchecked. But I think you are right. Because I remember that I was checking it some times. But it is unchecked now. Is there any file corresponding to it so that I could find and remove Konqueror from it? –  Bakhtiyor Feb 24 '11 at 12:42
    
Close all not wanted startup apps and press the "Remember the current running applications" button on the same tab, but leave the checkbox empty. –  nejode Feb 24 '11 at 13:40
    
The problem is solved. Thanks. So, the main factor for this problem was that button called "Remember Currently Running Applications". Somehow I clicked this button not knowing the meaning and at that time Konqueror had been started. The strange thing is that this button even don't ask confirmation. Anyway, thanks a lot. –  Bakhtiyor Feb 24 '11 at 15:04
    
See my answer. I found configuration file for that and it is more easier to solve my problem by just removing this configuration file. –  Bakhtiyor Feb 24 '11 at 16:20
add comment

Actually, the main reason for automatically running Konqueror after initiating session was that I pressed accidentally the button called Remember Currently Running Applications which is located in System>Preferences>Startup apps under the Option tab.

@nejode had guessed that first and posted his answer. In the comment he wrote that I can close all not wanted apps and press the Remember Currently Running Applications button again. I did that and it worked fine.

But, I started to look after the configuration file where this information is stored. Finally I have found it in ~/.config/gnome-session/saved-session folder. So removing all files from their will remove all remembered running applications. And I think it is more easier way to do that.

By the way, would be nice in future to see Undo button along with Remember Currently Running Applications button.

Cheers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.