Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I watch hulu on my second monitor the screen does not stay full screen when clicking on my main monitor. Is there a setting I can change to fix that?

share|improve this question

3 Answers 3

Unfortunately this is just one of joys-of-Flash. As soon as it detects it has lost focus, it'll shut back down to regular size.

There are a couple of workarounds that work in the same way:

  • Compiz's Enhanced Desktop Zoom (magnifier - whatever it's called!).
  • kmag (KDE's magnifier app)

Both allow you to zoom in on something on the screen and both allow you to do this on one screen without affecting the other. Zoom in on the Flash applet (or game, or whatever) and you're away!

share|improve this answer
    
I forgot about Enhanced Desktop Zoom ... all the shortcuts are disabled by default these days. –  Pykler Apr 8 '13 at 19:07

There is a better solution.

If you are in it for the kicks. Is to configure your machine to use Two X server simultaneously. This will allow you to keep focus on one screen. While still fully interacting with the other.

Basically you will run on X server instance on each screen , sharing keyboard and mouse in between them.

You will not be able to drag and drop applications between the two screens but except for that its quite nice. Since you can switch desktop independently on each screen.

I don't think unity supports this. At least it didn't last time i tried. So you might need to use another window manager.

share|improve this answer

There's a quite dirty hack to avoid this here:

http://al.robotfuzz.com/content/workaround-fullscreen-flash-linux-multiheaded-desktops

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.