Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my Ubuntu install on my MacBook Pro 9,1 (late or early 2012, IIRC), the graphical mode works fine. However, when I switch to a tty (Ctrl+Alt+F1-through-F6), the screen seems to completely turn off (not even the backlight stays on). I can return to the graphical mode, but the area where the dock usually resides shows random gibberish until I reveal the dock (I have it set to auto-hide).

I am using the nvidia proprietary drivers, with the Intel HD integrated GPU disabled and it's kernel module blacklisted (this machine has hybrid graphics).

When I use Ubuntu's recovery mode, I can see the text-only interface. If I select FailsafeX, then switching to a tty once I see the limited graphics mode dialogue pop up doesn't work.

I have tried the answer from: "Why does switching to the tty give me a blank screen?", and tried booting with nomodeset, but the issue remains.

share|improve this question

I'm having the exact same problem on a brand new Lenovo IdeaPad Y500.

The best lead I have so far is that the parameter "UseVbios" in nvidia's driver settings needs to be set to 0.

There are several theoretical ways to accomplish this, none of which work for me. So far, I have:

  • added a "nvidia.NVreg_UseVBios=0" in /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT parameter (and ran sudo update-grub afteward )
  • added a nvidia.conf file under /etc/modprobe.d/ containing the single line options nvidia NVreg_UseVBios=0
  • added an Option "RegistryDwords" "UseVBios=0" line to /etc/X11/xorg.conf under the nvidia Device section.

Neither of those appear to work for me. Most of the posts about it refer to UseVbios being one of the lines in the output of cat /proc/driver/nvidia/registry , but with my nvidia driver ( nvidia-current, 304.43), it's actually showing in /proc/driver/nvidia/params.

So I'm still hunting around for the proper voodoo to change that.

In the meanwhile, while I'm not quite ready to have my dog chew on my laptop, I can certainly relate to the sentiments expressed here.

*edit1: The first two methods can be made to work by using "nvidia_current" as the module name rather than nvidia. Interestingly, having UseVbios set to 0 isn't sufficient to fix this. Onward.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.