Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been trying for days now to install Eclipse on Ubuntu 10.10 but it never works. if I double click on Eclipse icon, it does nothing. I've tried to change permission and applying methods I found but none of them works. Also Software Center is not downloading or installing anything.
It shows errors similar to this one:

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick-backports/multiverse/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]
E: Some index files failed to download, they have been ignored, or old ones used instead.

OR

E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
share|improve this question
1  
@Aditya Maybe not. If it's really 10.04, the problem is wrong repos. (Btw, 10.04 is still supported, even on the desktop. So if this turns out not to be a dupe of that, we can definitely still answer it.) Aqsa Akbar: You said you're running 10.04. But you have maverick-backports enabled. Maverick is 10.10. If you meant you're running 10.10, please let us know--that means this is a duplicate of that question. Otherwise, you should fix your mixed repositories; if you're running 10.04, please provide the output of lsb_release -a and cat /etc/apt/sources.list (edit your question). –  Eliah Kagan Apr 6 '13 at 16:41
    
ooops i have 10.10... –  Aqsa Akbar Apr 11 '13 at 20:02
    
@eliah i checked that solution. i ran the commands and it gives these errors.. W: Failed to fetch security.ubuntu.com/ubuntu/dists/maverick-security/universe/… 404 Not Found [IP: 91.189.91.13 80] E: Some index files failed to download, they have been ignored, or old ones used instead. –  Aqsa Akbar Apr 11 '13 at 20:19
    
The problem is that you have only incompletely followed the instructions at How to install software or upgrade from old unsupported release? (which this can now be closed as a duplicate of). You have to replace http://security.ubuntu.com/ubuntu with http://old-releases.ubuntu.com/ubuntu, too. For example, if you're following that answer, make sure to do step 5. –  Eliah Kagan Apr 12 '13 at 1:53
    
i did everything that post said but it still isn't working... –  Aqsa Akbar Apr 13 '13 at 15:21

1 Answer 1

Maverick is no longer supported, so the packages were moved to old-releases.ubuntu.com. Please upgrade to a newer version or modify your sources.list

share|improve this answer
    
Modifying the sources.list will fetch newer files for eclipse on an older Ubuntu, which is not recommended. –  i08in Apr 6 '13 at 14:21
    
I meant pointing to old-releases.ubuntu.com, not changing from maverick to natty/oneiric/precise/quantal/raring. –  Dennis Kaarsemaker Apr 6 '13 at 14:22
1  
The asker said he has 10.04 Lucid Linx which is an LTS edition, and still in support until the end of this month AFAIK. –  Yekhezkel Yovel Apr 6 '13 at 15:09
    
Oh, missed that. Then they messed up their system already as it has maverick repositories enabled! –  Dennis Kaarsemaker Apr 6 '13 at 15:13
1  
@YekhezkelYovel Actually, a bit longer--through May 9th. (See the official announcement for details.) Even after that, lucid repositories won't go to the old-release server for years, though, because 10.04 LTS will remain supported on the server platform--so long as no community-maintained or GUI-related packages are used--through April 2015. (So far, LTS releases have been supported significantly longer for such server use.) –  Eliah Kagan Apr 6 '13 at 16:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.