Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried remotely connecting to Ubuntu 12.04 from windows 7 using remote desktop manager. After installing xrdp, I was able to login but was not able to see any icon on my Ubuntu Desktop. Even the right click does not work. This problem is same as referenced in the following link:

Blank desktop when logging in via xrdp

To get rid of this problem, I followed the following steps:

cd /home/youruser
echo "gnome-session --session=ubuntu-2d" > .xsession
sudo /etc/init.d/xrdp restart

But now, I am not even able to login the Ubuntu system. It displays a message "Failed to load session "ubuntu-2d". Don't know how to get rid of this problem. Searched on internet but was not able to get any significant answer. Thanks in advance for the help !!!

share|improve this question
add comment

3 Answers

I used the following:

gnome-session --session=gnome-fallback

http://c-nergy.be/blog/?p=3518

share|improve this answer
add comment

I struggled with the same problem on a new laptop with high resolution screen. I changed the resolution in the windows remote desktop client to a lower level 800x600 and reduced the color depth to 24 bits. After this change the ubunto desktop was shown (after login).

Note: Ubuntu 12.04 + I tried gnome-session suggestions first.

share|improve this answer
add comment

Had the same problem. In my case, the unity package had been removed during the upgrade + autoremove.

apt-get install unity unity-2d

solved the problem

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.