Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running a small IRC server on Ubuntu 12.10 using ircd-hybrid and i'm having a few issues setting a password for the server (setting a channel password works fine), I have tried setting the "password" in the user auth{} section in the ircd.conf configuration file, but when ircd-hybrid is restarted I can't access the server at all (I get the error message "you are not authorised to use this server", i'm using the password that gets generated by mkpasswd (not running it as root, either - tried using -m md5 option as well without luck) and I don't know what the issue is (I can connect just fine when the line is commented out). I've attached some snippets from our ircd.conf file which should help.

auth {
        user = "*";
        class = "users";

        /* restricted: stop the client sending mode changes */
        #restricted = yes

        /* Password to join server */
        password = "(our pass here)";

        /* Spoof users host */;
        spoof = "client.net";

        /* have ident: require the user has identd to connect (OLD I: + flag) */
        have_ident = no;
};
share|improve this question

1 Answer 1

Apparently mkpasswd generates a different hash each time it runs, rather confusing. Eventually figured it out

# mkpasswd -m md5 password
$1$lilSP/V0$bAHlfX24N2lcUS8BW/JDD.

...spaces in the name seem to be bad

Then in the config make sure you have

encrypted = yes;
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.