Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time I open a terminal or an application like Inkscape I have to click the maximize button because by default they open in a small size. Is there a way I can configure my system so that whenever a new program opens, it uses the whole screen?

Here is an example of how small the window of Inkscape is when it opens:

example of how inkscape (and any other application) opens small

share|improve this question
    
if you maximise the window, and close the program and open it the next time, the size isnt remembered? –  theTuxRacer Feb 24 '11 at 4:48
    
@Kaustubh, that is not the case for all applications. –  Oxwivi Feb 24 '11 at 6:09
    
it is certainly not the case for the Terminal and Inkscape –  amh Feb 24 '11 at 9:05
    
You can set it for the Terminal tho. –  Octavian Damiean Feb 24 '11 at 16:56
    
how can i set it for the Terminal? in any case, i want to set it for all applications –  amh Feb 25 '11 at 18:57

6 Answers 6

up vote 20 down vote accepted

Install maximus Install maximus from the Software Center or from the Terminal:

sudo apt-get install maximus

Then run this command from the Terminal:

maximus

All the new windows will be maximized with that.

Finally, just like in the screen shot at the 5th point in DoR's answer, add an entry in the Startup Applications. The name can be whatever you want, and the command will be simply maximus.

share|improve this answer
1  
I installed it. It is great. Thanks a lot for the recommendation! However, it does not do what I need. It maximizes existing windows. I want it to maximize the windows of the applications I will open. Not the ones I already have opened. –  amh Feb 24 '11 at 9:22
    
@andresmh, did you try opening anything while maximus is running? If you rebooted the system, unless you add an entry at Startup Applications, it won't run. –  Oxwivi Feb 24 '11 at 9:40
    
you're totally right. I put maximus so it starts at boot time and it now works great. Thanks! –  amh Feb 25 '11 at 18:58
    
Glad my bits of knowledge regarding Ubuntu could be helpful! –  Oxwivi Feb 25 '11 at 19:14
  1. Install devilspie Install devilspie. Devil's Pie is:

    A window-matching utility, inspired by Sawfish's "Matched Windows" option and the lack of the functionality in Metacity. Metacity lacking window matching is not a bad thing — Metacity is a lean window manager, and window matching does not have to be a window manager task.

    Devil's Pie can be configured to detect windows as they are created, and match the window to a set of rules. If the window matches the rules, it can perform a series of actions on that window. For example, I can make all windows created by X-Chat appear on all workspaces, and the main Gkrellm1 window does not appear in the pager or task list.

  2. Create the directory ~/.devilspie if it doesn't already exist:

    mkdir -p ~/.devilspie
    
  3. Now we'll create the script that will maximize all windows:

    gedit ~/.devilspie/maximize.ds
    

    Paste the following code into maximize.ds:

    (begin
        (maximize)(focus)
    )               
    

    enter image description here

  4. Run the following command from a terminal:

    devilspie       
    
  5. All your windows should now be maximized. Now add devilspie to your Startup Applications so you won't have to run it manually every time you login:

    • System ➜ Preferences ➜ Startup Applications

    • Click Add and enter Devil's Pie for the Name and /usr/bin/devilspie for the Command.

    • Click Add and close Startup Applications.

    enter image description here

share|improve this answer
    
This looks like a solution but I was hoping something that didn't have to run an extra process. I wonder how cpu/memory intensive this is. I was hoping I would just have to change some existing config files. –  amh Feb 24 '11 at 9:23
    
@andresmh devilspie is idle except when you open a new window, it is very light on system resources. –  Alvin Row Feb 24 '11 at 17:53

If you are using Compiz, go to "Window Management" (under categories or scroll down in the main window) and do the next:

DO NOT ENABLE WINDOWS RULES YET!

  1. Open "Window Rules".

  2. In the "Matches" tab, find "Maximized" and write class=

  3. Then enable Window Rules. (Check box on left or in main window)

Now, all your windows (and I mean: ALL) will ALWAYS open Maximized.

WARNING! This will also include dialogs, normal windows, and every window will act as you requested. This was your wish, right? always be sure that you really wish what you wish. :)

You can also do several things, which includes (but not limited to):

  • Enabling a single program to open maximized, by clicking the "plus" icon in the right side and pressing the "Grab" button in order to choose the window of the program. which should be running in order to do this, you can also write the title, role, type, name, etc.
  • Exclude a single program to not observe this feature by doing the last steps and making sure you enable the "Invert" button in the dialog box.
  • Use other windows rules, like:

Skip taskbar: in order to the windows won't appear in the task bar. Skip pager: this way the windows won't appear when you change an application by using [Alt][Tab] or [Super][Tab] Above: the windows will always stay above the rest of the windows keeping the focus always. Below: Useful when you wish an application, like the terminal, to be as "embedded" into the desktop. Fullscreen: doesn't need explanation. Non movable, Non resizable, Non minimizable, Non maxibizable, Non closable, Non focus: does what it says.

A screenshot is placed here for you to see this plugin's in action:

enter image description here

HOW TO OVERRIDE THIS WINDOWS BEHAVIOUR:

You will be in the need to gain access to compiz, and disable the "Window Rules" plugin.

If you did something that don't allow you to see compiz, (something like: making a window to stay "above" of the other and maximized or fullscreen), open a terminal and disable compiz by running: metacity --replace.

Good Luck!

The uppercase are just to emphasize important text. Can be edited and changed by anyone if needed. Thank you.

share|improve this answer

For regular Inkscape users which get annoyed by that problem there is a solution.

  1. Start up Inkscape.
  2. Maximize it.
  3. Go to File ➜ Inkscape Preferences ➜ Windows.
  4. Select Remember and use last window's geometry.

    enter image description here

  5. Always close it in maximized mode.

Now every time you fire up Inkscape it will load up with its saved geometry.

share|improve this answer

I you are using compiz you can also:

1) install ccsm from software center or sudo apt-get install ccsm. It's a compiz configurator

2) launch it from dash or from terminal

3) select windows placement and in the general tab change the positioning mode to maximized

I found this works quite well

share|improve this answer

1) Install CompizConfig-Settings-Manager,

2) Open Alt + F2 and type ccsm and hit Enter,

3) Go to "Place Windows"

enter image description here

4) Select "Fixed Window Placement" > "Window with fixed placement mode" > "New"

enter image description here

5) At "Windows" paste: type=Normal

6) At "Mode" select: "Maximize".

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.