Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here a screenshot (in danish, the english equiv can be seen here http://askubuntu.com/a/187657/107445, similar question but the answers does not solve the problem)

enter image description here

The very weird thing is, that this error only appears when I try to connect to a server from a nautilus opened as system user / gksudo. From a Nautilus opened as "anonymous" user there is no problems connecting to server. I am also able to connect to server from "places".

I have runned

sudo apt-get install gvfs-backends

and as suggested in this similar question http://askubuntu.com/a/187657/107445

sudo apt-get install --reinstall gvfs-backends 

also

sudo apt-get update

sudo apt-get upgrade

but still, this error appears, and only appears in Nautilus as system user. Does someone know the answer to this? I am completely stuck.

share|improve this question

1 Answer 1

I got this error when trying to run Nautilus outside a desktop session - I'd just connected in with "ssh -X ..." from another host and typed "nautilus &".

If I run:

dbus-launch nautilus &

Then the error goes away and it all works. This makes sense as GVFS needs a DBUS session context, so I'm happy this is expected behaviour on my system. If I was seeing this same error when running Nautilus on a regular desktop login then I'd suspect a configuration problem, but it would still be worth looking at DBUS as a culprit.

Maybe the developers could make that message more helpful!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.